Jump to content


Photo
- - - - -

LabSQL ADO slow on LV2010-64bit


  • Please log in to reply
2 replies to this topic

#1 MikaelH

MikaelH

    The 500 club

  • Premium Member
  • 657 posts
  • Location:Sydney
  • Version:LabVIEW 2012
  • Since:1996

Posted 11 May 2011 - 10:36 PM

Hi
I've converted one application from LV2010-32 bit to 64 bit.
Everything works well, but my LabSQL ADO component is slow.
In my 32-bit LV application a DB-queryl takes 4ms but 1700ms in my 64-bit system, it still works but I can't accept this.
A run both LV32 and LV64 on the same computer next to eash other so it's not a computer issue.

Anybody seen this before?
ADO_Slow.png
Cheers,
Mike


#2 MikaelH

MikaelH

    The 500 club

  • Premium Member
  • 657 posts
  • Location:Sydney
  • Version:LabVIEW 2012
  • Since:1996

Posted 25 May 2011 - 01:30 AM

Hi again
I'm going to give this problem one more push to see if anybody has tried to use the Database ADO Active-X with LV2010SP1-64 bit.
I've attached a VI that explains the problem.

A quick summary:

Iím running LV2010-32 and LV2010-64 at the same time on my W7-64bit computer.
I opening the attach VI in both LV versions.
I have an enum on the FP that executes 3 different queries.
Here is the time statistic for all the 3 queries:
2011-05-25_1124.png
Iíve a disable structure in the code to try two different ways of getting data, both give me the same result.

The problem is that when I'm getting NO data/rows back from the query, it takes LV2010-64bit ages to execute that.
Why?
Is there a ADO-64 bit Active-X Component I should use?
Cheers,
Mike

Attached Files

  • Attached File  SQL1.vi   33.27KB   122 downloads


#3 MikaelH

MikaelH

    The 500 club

  • Premium Member
  • 657 posts
  • Location:Sydney
  • Version:LabVIEW 2012
  • Since:1996

Posted 30 May 2011 - 10:21 PM

NI has found the problem and filed a CAR for this.
They did give me a workaround, that needs a small change in the LabSQL drivers.
Always before you get the the data, do a PropertyNode: _Recordset.EOF check.
EOF.PNG
Cheers,
Mike
  • jcarmody likes this