Jump to content
lecroy

Wow, only one undo?

Recommended Posts

You have got to be kidding me. Undo in 2009 only goes one back? I guess this new feature was to make me less sloppy and make less mistakes?

What the heck is going on inside NI now days?

Share this post


Link to post
Share on other sites

You have got to be kidding me. Undo in 2009 only goes one back? I guess this new feature was to make me less sloppy and make less mistakes?

What the heck is going on inside NI now days?

There's a LabVIEW.ini setting that you can set to 99.

maxUndoSteps=99

Share this post


Link to post
Share on other sites

There's a LabVIEW.ini setting that you can set to 99.

maxUndoSteps=99

This was not in the ini file, so I added it. Then restarted Labview. Same thing, only one undo. Does yours work?

Share this post


Link to post
Share on other sites

This was not in the ini file, so I added it. Then restarted Labview. Same thing, only one undo. Does yours work?

It works fine for me. (It must be some sort of conspiracy against you :ph34r:) Sorry, I couldn't resist... ;)

Sadly, I have no clue at where you should look to correct this otherwise. Perhaps directly in the Tools/Options... menu?(Environment Tab)

Share this post


Link to post
Share on other sites

It works fine for me. (It must be some sort of conspiracy against you ph34r.gif) Sorry, I couldn't resist... wink.gif

Sadly, I have no clue at where you should look to correct this otherwise. Perhaps directly in the Tools/Options... menu?(Environment Tab)

Could be but I doubt it very much.

Are you using Version 9.0 (32-bit) for Windows? Under the options, it is set to 10 per VI.

The following is my current ini.

[LabVIEW]

IsFirstLaunch=False

menuSetup="default"

saveFloaterLocations=True

find.viListFlags=4

LastErrorListSize=0,0,379,484

paletteStyle="NamedIcons"

RecentFiles.pathList="xxxxxx"

SaveChanges_ApplyToAll=True

PropPageBounds="1672;292;2168;751"

ScaledToFitVisible=False

ScaledToFitLocation="84,67,859,1043"

enableAutoWire=False

autoRouteWires=False

ShowConstantFolding=False

ShowConstantFoldStructs=False

postScriptLevel2=False

FancyFPTerms=False

NoAdvice070=",FlatSequence"

SnapGridShowsOnFrontPanel=False

FPFont="0" 13

colorHistoryItemA=00A0F8FF

colorHistoryItemB=00E8FF2A

colorHistoryItemC=00FF0000

colorHistoryItemD=00730000

colorHistoryItemE=001E4B00

colorHistoryItemF=0064FF00

colorHistoryItemG=00FF0001

colorHistoryItemH=00B3B3B3

colorHistoryItemI=00FF1231

colorHistoryItemJ=00000E42

colorHistoryItemK=006C8292

NewDlgRecentMainTemplates.pathList=""

NewDlgBounds="800;600"

NewDlgRecentTemplates.pathList=""

NewDlgLastSelected="A09C6440-BBD9-4508-9462-C3AAAD503B2A"

NewDlgSmall=False

NewDlgCollapsed="77E350A8-F9AA-43FF-85E2-454279EBB9A7"

LLBMgr_ActivePlugins=""

LLBMgr_RecentPath="xxxxxxxx"

ProjectExplorer.ClassicPosition=29,1427,429,1757

AutoSaveEnabled=False

SnapToPresetsBD=False

SnapToPresetsFP=False

autoerr=2

LogFileSaved=True

LaunchConfigurationPageAfterDropExpressBlock=False

autoInsertFeedbackNode=False

StructuresAutoSizeByDefault=False

ShowRedXOnWire=False

transparentBDLabels=False

recentUserName="xxxxxxx"

RecentFiles.project="xxxxxxxx"

ShowPathInProjectWindow=True

ProjectExplorer.ProjectItemsColWidth=254

editRecentPaths="xxxxxx"

toolPaletteLoc=880,1147,1029,1225

autoToolOn=False

maxUndoSteps=10

Share this post


Link to post
Share on other sites

Yes, 32-bit WinXP.

Another person here is going to install it on another PC. We will see if they have the same problem. Could be NI has something against our company and not just me.

Share this post


Link to post
Share on other sites

Works for me too. LV2009, 32-bit, WinXP.

What have you tried to resolve it?

Have you tried renaming your ini and letting LabVIEW recreate it and then copying over your desired settings?

Share this post


Link to post
Share on other sites

In 2009 this can also be set from Tools >> Options >> Environment >> Maximum undo steps per VI. Probably a bit safer doing it from here then editing the .ini file.

Share this post


Link to post
Share on other sites

In 2009 this can also be set from Tools >> Options >> Environment >> Maximum undo steps per VI. Probably a bit safer doing it from here then editing the .ini file.

That was already covered above.

Renamed INI, restarted LV. It created a new INI with defaults. Undo is still only one deep. My guess is it's inside the Labview code. 2009.1 will be out soon.

Share this post


Link to post
Share on other sites

Is this on a specific action you're trying to perform or in any action? There are certain operations in LabVIEW which clear the undo buffer.

Share this post


Link to post
Share on other sites

Because there are so many versions of each OS, like Vista and XP ... I am running XP Pro 64-bit, Version 5.2 SP2.

Erase two wires, can only get one back. Erase two locals, can only get one back. Move two items, can return both to their original positions. Erase one wire, move one item, can return item to original position but can not get wire back. Did not do a lot of testing on this but it appears related to the erase.

Remember when there was no undo?? At least this new version doesn't take me back that far.

Share this post


Link to post
Share on other sites

Are you using some tools that have some scripting in it?

I know (because the RCF use to have this pb) that using some scripting action will flush your undo buffer and you end up with only one undo (regardless of what you set the ini settings).

Just a though.

PJM

Share this post


Link to post
Share on other sites

Only one undo? No. In fact, LV 2009 increased the default undo size from 8 to 30.

Works well on my machine, both my PC at work and my Mac laptop.

Share this post


Link to post
Share on other sites

I'm not saying this is the cause, but if you say 64-bit XP to NI they say:

http://digital.ni.co...6256E61006568C8

Also see:

http://zone.ni.com/d...a/tut/p/id/5709

Bruce

I do not run the Labview programs on the XP-64 machine. They are only developed on it.

I have no scripting programs running. As a matter of fact, I shut down everything when using Labview. Previous versions of Labview Undo work fine on this same PC. This is a new feature for 2009. Something they decided they had a better way to impliment and did not do a good job of testing.

Share this post


Link to post
Share on other sites

I as well am using 2009 and with Win 7 and all is well with my usual user defined value of 38.

I'm thinking something is hosed on your system LeCroy. I hate to mention it.... have you though of uninstall/re-install?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.