Jump to content
ensegre

keep focus in a subpanel control

Recommended Posts

I ran into this; I wonder if I'm misunderstanding, or it's a bug.

 

post-28229-0-87144600-1442835444.png

 

I have a FP, with buttons I want to toggle with keys, and I have string controls in a subpanel, like in the attached minimal example. I'd like to toggle the button while the focus remains in the subpanel string. While this is no problem for a control on the FP, pressing F1 while focus is in the subpanel string rises the focus to the whole subpanel container. What is wrong? If a bug, how to workaround? Setting KeyFocus to the sbubpanel string ref doesn't seem to help.

 

Seen in 2014SP1 linux and 2014SP1f3 windows.

main.vi

subvi.vi

Share this post


Link to post
Share on other sites

Right, it works. I thought I also tried that, with the continuously running subvi. Oh, I see -- I set the subvi property as "run when opened" and just inserted it in the subpanel -- forgetting that VIs in subpanels are not "open". Thanks for the tip... :thumbup1:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.