Jump to content
News about the LabVIEW Wiki! Read more... ×
Tim_S

Issue updating VIPM from 2017 to 2018

Recommended Posts

Posted this on the JKI VIPM forum a week back but haven't gotten a response yet.

I've installed LabVIEW 2018 which also attempted to update VIPM. LabVIEW installed OK, but VIPM failed to install. Been getting the message "The older version of VI Package Manager 2018 f1 cannot be removed. Contact your technical support group." Anyone seen this before?

Tried uninstalling VIPM then reinstalling through LabVIEW installer with no luck.

Share this post


Link to post
Share on other sites

Think I've narrowed down the cause... the uninstaller for VIPM 2017 is not on my hard drive anymore. The error message is misleading as the 'older version of VI Package Manager 2018' is actually version 2017.

Share this post


Link to post
Share on other sites
5 hours ago, Michael Aivaliotis said:

Don't use the NI LabVIEW installer. Use the installer distributed from JKI. Uninstall VIPM then install it form JKI. Never use the NI installer for VIPM.

Hey Michael,

Thanks for the insight. Could you release the installers for the older versions of VIPM so we can fix VIPM installations that got updated/broken by accidentally installing a new version of VIPM with an update of LabVIEW over the top?

That would be awesome :)

Share this post


Link to post
Share on other sites

I'm sure if you request that from JKI, they could help. But last I recall VIPM typically installs the installer in:

C:\ProgramData\JKI\VI Package Manager 20xx\updates\VIPM

This might have changed, but try there. Also, if the setup isn't there, look for the vipm-update.aiu file in that area. It's a text file that includes a URL to the installer.

PS: I don't work at JKI.

Share this post


Link to post
Share on other sites
3 hours ago, Michael Aivaliotis said:

C:\ProgramData\JKI\VI Package Manager 20xx\updates\VIPM\vipm-update.aiu is a text file that includes a URL to the installer.

Great, that helped. There's no installer but I've never been brave enough to look inside that file. Got what I need now.

Cheers

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.