Jump to content

help me to read data from pic18f452 to labview


Recommended Posts

Hi,

I'm currently using labview to receive data sent from the microcontroller PIC18f452.

The principal idea for my project is to send the weather sensor results from the first PIC and then receive it in the other PIC(THE TWO PIC ARE THE SAME - PIC18F452-)and then send it ..

I'm using visa to receive data from the pic. But the problem is the read result always zero!! I'm be ensure that the baud rate for labview and proteus is same I'm use a virtual serial port to interface Proteus with labview.. Also i connect the RS-232 in Proteus to a virtual terminal to enable me to see what is sent.. Although there is an output in this virtual terminal and i see that data is sent (but not alwayes!! som times it dosn't appear any thing); i cant see that this data is sent to labview.. also the baud-rate of sent and received bytes in Virtual serial port is zero>> this picture show the problem

please >> i need your help>> and i need someone to advice what to do or what i need to solve the problem ..

Regards

post-19581-0-28061600-1295534096_thumb.p

post-19581-0-58454500-1295534104_thumb.p

post-19581-0-37719300-1295534120_thumb.p

Link to post
Share on other sites
  • 3 years later...

Hi EVERYBODY

 

I'am student, and im working on project thats im using LABVIEW (2010) and Pic 18f4550 (USB connection).

I wrote my program on LABVIEW, and i program my pic in MICRO PRO C (version 5.60) 

the program of the pic is to read what i write (i mean i write text and i must receive the same text).

i installed Visa, and i arrived to make the connection between ISIS and the LABVIEW (i mean i test everything vitually)

but when i write the text, the pic receivit without problems, and the pic doesn't send me the text, and i the LAbwindows show me that i have problem in this function (visa read).

Actually i dont know the problem, and i need ur help because i need to start working practiclly on the project soon, and i nees to make sure that virtually i dont have no problem, and im afraid to have the same problem in realitty.

 thanks 

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.