Jump to content

Jon Sjöstedt

Members
  • Content Count

    32
  • Joined

  • Last visited

Community Reputation

0

About Jon Sjöstedt

  • Rank
    More Active
  1. Hello all! The attached code does not work (my hardware is a USB6341). For some reason the task does not accept new samples when the second loop is run and the "wait until done" in the second loop causes a "buffer underrun" error -200621. Any ideas? Buffered DO task run multiple times.vi
  2. Hello! Thanks for the examples-tip. I have gone through a large set of DAQmx-examples and now I have a much better idea on how to aproach my problem. New question is (the initial problem is altered a bit to simplify the requirements for the IO-box): I want to create a task that is triggered by /dev/do/StartTrigger, but I cant see how to select which internal terminal to connect with the do/StartTrigger. MAX contains a map on which connections are possible, but I cant see how to use that to configure a connection or how to do it in LabVIEW. I want to do it in LabVIEW.Any ideas?
  3. Hello! I need to create a pattern that is made up from four digital outputs which are pulsed at well defined timeings. I have borrowed a NI USB 6341 and done some tests. Unfortunately the documentation is very poor, and leavs most real technical questions unanswered. I would like to create something like this: * Ctr0-Ctr2 are driven by 100MHz timebase * Configure Ctr0-Ctr2 to generate a trig-start for port0.0-port0.2 after different delays * Output data at port0.0-port0.2 when Ctr0-Ctr2 trigs them * Output from port0.0-port0.2 are made up from two samples (HL) and timed by something else than the 100MHz timebase Is that possible? I use LV2010 on Windows If there exists a real technical reference for the USB 6341 that someone can point out, I would like to read it. 370784c.pdf is the best i've got so far and it is in no way complete IMO.
  4. Hello all! I have just started experementing with VISA Events. I have previously done a lot of VISA polled stuff. I have supplied a simple example that can be used to demonstrate that STB is not updated with the expected value until a coresponding event is read off of the event queue. For those who dont have lv2010 the code does this: * Setup a VISA session for handling the SRQ-event * Issue *CLS *ESE 61 and *SRE 52 *Issue '*IDN?;*OPC' While loop until an error occur: *Wait for event *Close event if no error occoured *Read stb When executed withput delays, two events are produced, one for MAV set and one for OPC set This makes sense. But if delays are introduced, for example by placing a breakpont before reading the first event, I would expect STB to have both MAV and OPC set, but this is not the case; only one of them are raised (usually MAV). This does not make sense to me. What makes STB return a value that seems to match what the latest event produced, rather than what could be expected to be in the instrument? Any ideas appreciated! VISA-Event test-monitor events flow.vi
  5. Hello all! During a measurement with the same set of calls over and over again I eventually get the error -1073807239. According to google, this seems to be an unusual error. The equipment involved is: A SUN workstation with "SunOS a5.9 Generic_122300-44 sun4u sparc SUNW,A70", lv 7.1.1 and an Anritsu MS2691A The repeated command sequence is : INIT:IMM;*OPC FETC:CHP? The calls also sometimes experience -1073807339 errors, tbut they are resolved by repeating the failed command Any ideas?
  6. Problem solved: This error was caused by sending any unrecognized command to the device. Funny implementation...
  7. The error comes from VISARead (not STB or something else that one could expect to be involved) TCPIP::132.196.224.237 The instrument answers fine on ping All other visa calls works
  8. Hello all! I keep getting the -1073807344 error from VISA when trying to do VISA read from a piece of hardware (defined as "piece of hardware", since it is designed in-house and I cant get much info on what it is, execpt for 2-3 documented SCPI commands) VISA write is no problem. Any input appreciated!
  9. Thanks for all help! I will try the NI-forum
  10. Hello! Here is some possibly useful data: Loaded modules lsmod | grep -i ninipalk 1843664 2nikal 91592 3 nipalkusbcore 150312 5 nikal,usbhid,uhci_hcd,ehci_hcd Labview crashes when executing "VISA Find Resource" linux-rrel:~ # /usr/local/natinst/LabVIEW-2009/labview &[1] 5787linux-rrel:~ # FATAL: Module gpibprtk not found.[1]+ Aborted /usr/local/natinst/LabVIEW-2009/labviewlinux-rrel:~ # Interactive GPIB tool crashes the same way (on startup): linux-rrel:~ # /usr/local/natinst/ni4882/bin/gpibintctrlFATAL: Module gpibprtk not found.Abortedlinux-rrel:~ # I have attached the simple code that crashes LabVIEW. It is saved in lv2009 format Hope this helps. And thanks so far VISA_Find.vi
  11. The NIKAL NIPAL are both loaded (seen using lsmod) and LV itself works fine. I have tried updateNIDrivers and installing the drivers supplied with the GPIB-PCI bridge without success.
  12. Hello all! I have just installed lv2009 on SLED 10 SP2. Pure lv works fine, but "VISA find" on GPIB0 (which mapps to an internal GPIB-PCI bridge) crashes lv and returns something like "gpibprtk" module missing. The same happens if I try to run "interactive" from gpibexplorer. I can not find anything in the local file tree that seems to be a loadable module named gpibprtk. Any ideas or suggestions on this appreciated!
  13. Guess I have to seek other solutions. Default values or adding a boolean.Hmm... Thanks anyway!
  14. Hello all! How can I (programatically) detect if a terminal of a VI is wired (inside that VI with the possibly unwired terminal)? Comparing with a default value is not an acceptable soulution. I started thinking property node but got stuck there.
  15. Hello all! It feels silly to ask, but how can I remove a file from an llb in lv7.1?
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.