Jump to content

Ano Ano

Members
  • Content Count

    132
  • Joined

  • Last visited

Community Reputation

0

About Ano Ano

  • Rank
    Very Active

Profile Information

  • Gender
    Male

LabVIEW Information

  • Version
    LabVIEW 2015
  • Since
    2009

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Dear ensegre, I just send you a PM
  2. Dear ensegre, As you can see from the attached picture, some vi's are missing from the "Image Management" menu and the External Library Support menu is missing. Any idea what I forgot to install? Maybe its an incompatibility between LV17 & Vision 2016.
  3. Thank you very much for your prompt answer. I would prefer if I could find just those 2 vi's rather than re installing the suite -It takes ages! These two vi's are the only ones missing to get the thermocamera's vi's working. I no longer need NI Vision's full capabilities so there is no other need to roll back to LV15. If you have these vi's please upload them. Thank you in advance
  4. Dear kanchi101, I did not find a solution via Modbus. I ended setting motion tasks via the Kollmorgen workbench software and controlled these via sending a set of boolean logic signals. These signals can be registered on the Digital I/O section of the Kollmorgen Workbench software. I also read the position of the motor via the analogue out of the drive. If you need more info let me know
  5. Hello, I recently upgraded from LV2015 to LV2017 and although I have the Vision 2016, the new installation somehow deleted(?) two useful vi's. Can anyone please upload the: IMAQ Cast Image IMAQ imagebordersize Anyone knows why this happened? Thank you in advance
  6. Hello, I am trying to familiarize myself with ActiveX & excel and I am using a vi (attached) that I found online. and when I run it excel opens up and in the graph the plot legend has 7 plots listed instead of 1. How can I change this to go according to the number of plots I actually have? Thank you in advance Add Graph and Format Legend.vi
  7. Hello, I am trying to use the Report Generation Toolkit to input nth XY plots in excel. I can input the data in excel but when I try to use the LV function to plot them, at best excel uses the first column as an X-Axis and the rest columns as nth-Y-Axis. Does anyone know how to plot multiple XY axis in excel? Thank you in advance
  8. Hello, I have a NI USB-6001 and I am trying to run the attached simple vi and I get an error 200279. It supposed to just acquire an analogue & a digital signal. Can someone help please? Thank you in advance AI & DI 1.vi
  9. Hello, In the the attached vi there is the followiing operation: When the boolean (Acquire) turns on, an array starts to fill with data, when that boolean turns off the user can decide to "keep" that 1D data by pressing a boolean button (Keep) and thus incerting that 1D array into a 2D array. When the user repeats the process the 2D array should populate accordingly; one row of 1D data each time the keep is pressed. As you can see from the attached vi, when the user presses the keep button, the 2D array continuously fills with the acquired array. I "prevented" this by adding a 1sec timer but its a bit unstable. Is there another way of doing this? Thank you in advance 2D array filling.vi
  10. Thank you both for the prompt answers. The application is for testing a strain sensor against an increasing load. The aim is to start the vi and then press a start boolean button to start acquiring data until another boolean stops the acquisition. The acquired multichannel data need to be plotted against time, starting at 0sec and ending ie 10sec later. When the user presses the start button then the graph starts at 0sec and plots the new data. Thus my weird X-axis if for counting the time passed in sec while the boolean is true and all this on-off is what is causing the buffer issues. Any ideas?
  11. Hello, This is probably a silly question but my mind is stuck! Attached there is a simple voltage acquisition vi. The aim is to have a case structure in a while loop and acquire-plot data from a sensor when the case structure is true. The displayed data needs to be plotted against time in seconds starting from 0 and ending in Xsec. Each time the case structure is true, the x-y graph needs to display the new data with the time starting at 0. The vi does not do that, instead the old data remains on the graph and on top of that the vi gives an Error -200279 after a while. What am I doing wrong? Voltage - Continuous Input.vi
  12. Hello, I have a graph with data as follows: X Y 0 1 1 4 2 15 3 33 4 48 5 64 . . . . 100 200 and I want to "stretch" the Y-axis data like: X Y 0 1 1 y2 2 y3 3 y4 4 y5 5 y6 . . . . 100 500 ie I want the same y-axis starting point, a new end point and the same number of x-axis points. I dont mind more y-axis points, just to preserve the shape of the curve. Any ideas?
  13. Hello, I have an acquired string (not array) that has a repeatable pattern: 2014062414:17:50.401B 0E 0E 2014062414:17:54.603 0E 0E 2014062414:17:55.648D 0E 0E 2014062414:17:55.862A 0E 0E 2014062414:57:10.786 0U 0U 2014062414:57:11.841 0U 0U 2014062414:57:18.112 34 11111 2014062414:57:19.157 34 11111 .... This is an array made up from a time-stamp and certain values (settings). The aim is to convert it to a 2D array and each row will be a 4 element 1D array in the following format: 2014062414:17:50.401|B|0E|0E| where "|" is placed to denote a different cell. The problem is that that the array has 1,000,000 time-stamps & set of settings ie a few million characters, hence using loops to manipulate it make my pc run out of memory! In addition the second setting "B" in "2014062414:17:50.401B 0E 0E", sometimes it appears, sometimes its another word character (ie A) or sometimes its a "space" character, always attached to the time-stamp. I am looking for a way to create a space between the time-stamp & the character if present in order to, further down the line, create a column with the word characters. Any suggestions? Thank you in advance
  14. Hello, I reached to a good point in detecting when its a straight line (T) and curve (F) in an array. But my mind is blocked on how to extract Nth arrays of straight lines! Please check the attached code and tell me what I am doing wrong Differentiator and Smoother.2.vi Savitsky-Golay Differentiator Core.vi Second derivative 5.vi
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.