Jump to content

gnshmrthy

Members
  • Content Count

    26
  • Joined

  • Last visited

Community Reputation

0

About gnshmrthy

  • Rank
    More Active

LabVIEW Information

  • Version
    LabVIEW 2012
  • Since
    2011
  1. Dear Friends, I've a requirement of controlling the input from LabVIEW and updating the graph value to the webpage and display the graph in same network. I tried using the web publishing tool, but it requires LV run time engine. Is there any other solution to display the graph in webpage? Regards, Ganesha Moorthy
  2. Dear All, I really appreciate all your suggestions and thoughts. Initially I left the option of LabVIEW 8.xx Layout by viewing this http://digital.ni.com/public.nsf/allkb/BAF0ACFA708F1D19862574C8005248E7 , enable it only when you build an LabVIEW developed in earlier version of LabVIEW 8.xx. But I've developed in LV12. When I tried referring different search results I found this http://zone.ni.com/reference/en-XX/help/371361J-01/lvconcepts/build_checklist/ , here they have added up for dynamically calling VI's use the LabVIEW 8.x file Layout. By enabling the function it worked. I can able to copy the application (.exe) to different location and run it successfully. But why are there two different solutions for an single option?
  3. Hi hoovah, I`m placing the snippet of our project structure and the build source file structure. Is there any suggestions on the build? Hi Queue, Since the size of class is too high and when I try to load it to always included, LabVIEW stops abruptly showing Not enough memory. My system configuration is good for the build which has i3 32 bit processor, 4GB RAM, 500GB hardisk, C specifically has 94.3 GB of free space. We have also increased the memory size of LabVIEW to 3GB from it's default 2GB processing. From the above attached, comm, DAQ, Prompt, State, Test, Report are class specific. User Interface is the top level VI of all the classes. Since we are using sub panel to load some of the VI's dynamically I couldn't able to debug the exe at Run time engine.
  4. Hi Tim, Yeah I tried the installer in a different PC. on different drive locations. But still the same problem? When I try to copy from E to D then build the application at D once again it`s working fine. During build does LabVIEW creates any path dependency to it's build folder?
  5. Dear Friends, I've an Project which is using CAN, DeviceNet, EtherNet/IP, ProfiBus communication protocol. All this protocol are called structured using LVOOPS concept. When I try to build an application (.exe), There is no issues in running the application. When I copy the folder and try to run in different PC i'm not able to run the functions in application which is having the class called in it. May I know should I use any specific steps to build an application with custom class. Regards, Ganesha Moorthy A
  6. Hi Hooovahh, Yeah you are correct, But here the Last VI is still running and only its front panel is closed. I hope because the while loop has not stopped the VI is still running. When I try to call back the initial VI still an error pop`s up stating that the front panel is closed. This time I`ve attached the code of the screenshot VI. welcome.vi Select the type of test.vi
  7. Hi Hooovahh, I`ve attached the code which i`m calling as you suggested. In welcome vi i`m calling the configuration VI as a SubVI and in Configuration vi calling the reference of welcome vi and closed it`s front panel.
  8. Hi Hooovahh, I hope i`ve not shown a clear picture. I`ve more than 5 VI`s 1. welcome, 2. Configuration 3. selecting a database file 4. selecting a type of test 5. testing VI. On every VI i`ve enabled with the property of "show front panel when called" and i`m closing it in the initial stage of the another VI (example i`m running the welcome VI and on user event i`m calling a configuration VI and closing the front panel of welcome VI in the initial of the configuration VI and so on).
  9. Hi Hooovahh & NI, Thanks for the portraying the issues. When I searched for the error cause the result was Memory leakage or invalid access of memory. When I restarted it the crash resolved.
  10. Hi friends, I`m getting a crash report when I was trying to run an example VI of an third party instrument (Sorenson Power supply XG 300-2.8). This is my first crash so not very much clear about the reason behind it.
  11. Hi Friends, I`m calling a VI by selecting the properties in windows apperance of " Show front panel when called" & " Close Afterwards if originally closed " and closing the VI using the invoke node of the reference. Is this a proper way to do it. even if I close the VI it`s still running in the memory is it only because I didn`t stop the VI or calling it wrongly.
  12. Hi Logman, You are correct the column names were the primary key for the error. I`ve updated the column names and also added the S.No for the tables which has more than one row. I used the S.NO as the particular element to update the values in the corresponding rows. Kudos.... The link for SQL is great thanks for the knowledge sharing.
  13. Hi Logman, I just want to update all the value to the database. I`m passing a numeric values of (Long and double), in some cases I also use string. The images of my screen are Sorry I really didn`t get the theme of the description described in help menu.
  14. Hi friends, I`m trying to update the values to the data base, I get the following error "NI_Database_API.lvlib:Cmd Execute.vi->NI_Database_API.lvlib:DB Tools Update Data.vi->Insert_Update Table and Data to the Database.vi<ERR>ADO Error: 0x80040E14 Exception occured in Microsoft Office Access Database Engine: Syntax error in UPDATE statement. in NI_Database_API.lvlib:Rec Create - Command.vi->NI_Database_API.lvlib:Cmd Execute.vi->NI_Database_API.lvlib:DB Tools Update Data.vi->Insert_Update Table and Data to the Database.vi" I didn`t connect the condition terminal, I`m not sure what should be done with the condition terminal at the Update VI. I tried connecting the terminal with the empty string or string constant still the same error. Thanks, Ganesh
  15. Sorry right now we don`t have the license, only if we do something which suit our application we will be able to justify the license for the cost. I hope the knowledge base links will help to get through.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.