Jump to content

Runtimeless Installer and LabVIEW applications

Recommended Posts

Running LabVIEW exe's without installing runtime? - Yes, you can.

Slides, working demo and source VI's for creating Runtimeless LabVIEW exe's for Windows OS. How to use this technique to create a LabVIEW installer to deploy applications with multiple setup exe's. How to create an autorun install CD just like the professionals - with custom Icon for the CD Drive and a custom installer program of your liking - because it's written in LabVIEW!

This was a topic in the June 2003 Southern California LAVA User Group.

Does not include the NI-DAQ driver install files due to file size.

Download File:post-12-1073109469.zip

Link to comment
  • 3 years later...


Does this still work in LV 8.20??? I am trying to deploy an executable to other users(PC's) within my company without needing admin rights. I tried placing both lvanlys.dll and the lvrt.dll in the same directory as the exe as well as using the key DLLPath in the exe's ini, but received the following errors:

1. The dynamic link library NINI32.dll could not be found in the specified path C:\Documents and Settings\dmiller\Desktop\...

2. Unable to locate the LabVIEW Run-Time Engine.

Has this ability changed in the last couple of release??? I contacted NI, but was told they will only support the scenarios where their Application Builder is used to execute the Runtime installer.

Any help will be really appreciated since all other options I am looking at require writing much more code. I am somewhat stumped at what to do next. And yes I realize this Runtime issue only happens the first time, but sometimes we can wait more than a week for IT to respond. Kind of makes my code worthless when some has to wait a week to us it.


Link to comment

I understand the headache of the IT department deployment schedule. We ended up getting them involved by having them make the LV RTE installable via a script.

Anyway, I think you'll have to include a little bit more stuff to get your application to run without installing the rte. You can find out what "stuff" in a couple ways. Run your program and everytime it asks for a DLL, find it on a machine with the RTE and copy it over to the machine without the RTE... OR, copy the contents of the Program Files\National Instruments\Shared\LabView Run Time\8.2 directory with your EXE and see if that works. That is esstially what Jack did with his 7.1 example. Its just that the RTE has gotten more complicated and bigger with the 8.x versions of LV.

Let us know what you come up with here on LAVA in case others need this info in the future.


Link to comment


I have actually tried this approach...I duplidcated the entire C:\National Instruments\Shared over to a 2nd PC with no NI software installed and ran a simple LV built exe(While Loop with a Stop Button) and recieved the same error. I have also copied the lvrt.dll and lvanalys.dll into the same directory as simple exe with the same results. It just can't seem to find the Runtime Engine. It is almost as if the only path that it searched for the Runtime is what is registered(ie by running the Runtime Installer)??? This seems to have changed since Jack's document and from what I remember.

If anyone has a bare PC with no Runtime Engine and could verify my results it might convince me that I'm not doing soemthing wrong. I have done exactly what Jack described in the past so I am really stumped by this and totally frustrated!!!


Link to comment
Have you copied all the DLLs that the EXE looks for into the directory with the exe? Sorry I can't help you more, but like I said, I got the IT department to take care of my runtime problems for me. I don't have any blank machines to try your idea out with, the LV RTE is one of the first things I install.

Good Luck,


I tried to get this to work and I also failed. Luckily for me, my app was able to down-convert to 7.1 where the trick still works.

Link to comment

I just did the following:

Installed the RTE

Verified that the test exe worked.

Copied the entire C:\Program Files\National Instruments Folder to the desktop

Uninstalled the RTE

Deleted the entire C:\Program Files\National Instruments Folder


Cut & pasted National Instruments Folder from the desktop to C:\Program Files\National Instruments

Ran exe

Received the same errors

Copied missing NIINI32.dll on dev. machine and pasted into corresponding RTE path

Ran exe and application loaded

Selected a FP control and received the following error: THe instruction at "0x303ea3bf referenced memory at 0x00000000". The memory could not be "read"

Something isn't making sense and it looks to be with something other than lvrt.dll


Link to comment

Yes...too many to list. I still wonder how the registry plays into this. From the LV built exe point of view, if all the files are in the correct place it should matter. Unless the RTE invokes certain queries for path entries withing the registry. If that is the case, there is probably no easy way around this problem and things have definetely changed over previous versions.


Link to comment

Here's another shot in the dark, but while you are trying stuff...

Try flattening the Program Files National Instruments, in otherwords, move everything in that directory structure to one level and place your exe there. Don't know if it will work, but it might be worth trying...

Ahh for the days of LV 4! Executables with the runtime built into the exe...

Link to comment
Ahh for the days of LV 4! Executables with the runtime built into the exe...
If my faulty memory serves this morning (only the first cup of coffee), this worked up through 5.0.1. It was the 5.1 version that did away with single file executables. I wonder what the minimum file size would be for 8.2 to do the same thing with all the new goodies we have?
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.