Jump to content
Sign in to follow this  
Paul

Upgrading the _dsc library

Recommended Posts

I am new to labview and I had a question to ask. :) I am modifying a labview program that was writte on 6i. At the same time the company that I work for decided to upgrade the machine that it was written on as well as the version of labview. Then switched to 7Express (the did it before 7.1 was out). I tried copying the all of the vi's that were associated with the old program to the new machine and loading them up. When I would boot up I would get a message saying that 3 of the sub vi's could not be located. They are dsc_EngineStatus.vi, VI_IsInitalized.vi, and dsc_Ivinit_starter.vi. I called up ni and apparently they stated that with 6i my company had purchased the _dsc library that was calling these vi's which 7 does not have. :headbang: They said that I would have to purchase the new library to get my older program to work. I went ahead and opened the directory in the old machine and tried saving those 3 vi's and trasnfering over, but the block diagram was protected and 7 would not read it. Does anyone have any other ideas or ways that I could get this program to run on 7 without purchasing any additional software packages. All ideas are welcome. Thanks.

Share this post


Link to post
Share on other sites

Paul,

Did you try to install the 6i Version of your DSC-package on LV7? It might work, I didn't do it.

Just by copying the files wouldn't work because the DSC has a whole engine (with a database) running in the background. It is based as a client-server system. At least you'll need the whole client part (if the server with the database is running on an other machine).

Didier

Share this post


Link to post
Share on other sites

That sounded like a good idea to me too. I asked my superiors and unfortunately they can't locate the dsc library CD because it was purchased such a long time ago and no one knows where it is :oops: . The only thing that they were able to find was the labview 6i CD which does not have that library on it. One of the NI representatives said that if I had the dsc runtime program, I could complile the library into a .exe and transfer it to a different computer. However, I don't have that either. Anyone else have any other ideas?

Share this post


Link to post
Share on other sites
I went ahead and opened the directory in the old machine and tried saving those 3 vi's and trasnfering over, but the block diagram was protected and 7 would not read it.

Are you sure you did this correctly? Even if the block diagram is password protected, LabVIEW should still be able to load the VI and recompile it for the new version. I think it's more likely that the 3 VI's are calling other subVI's that you didn't bring along to the new machine. It could even be a DLL call that cannot be made because the DLL's are missing. Who knows?

Create and save new blank (Untitled) VI in 6i and plop the 3 VI's on the diagram of this new VI. Now from the menu select File>>Save With Options. Make sure you select Save entire hierarchy in the dialog box. Also select include vi.lib files and external subroutines.

Save to a different directory and then try opening this Untitled.vi in 7.0

post-15-1086581745.gif?width=400

Share this post


Link to post
Share on other sites

Hello Paul,

Looks like you first had LabVIEW 6.1 and DSC 6.1. Then you moved to a different machine with only LabVIEW 7.0 (but no DSC). And you want to run those VIs. I am afraid this won't work.

Even if you find and get all the VIs and the DLLs, there are other things in DSC like the DSC Engine, the Citadel database, system services, built-in servers and proxies, third-party servers, etc., which would make it impossible for you to run the DSC-created application on just pure LabVIEW (assuming your app does indeed use the DSC features).

At the minimum, you would need a Run Time System of DSC (different from the LV Run Time Engine).

What you can however do is, install the DSC 6.1 on LabVIEW 7.0. This combination will work fine. If the DSC 6.1 CD is missing, you may want to contact your NI Sales person to get it replaced. I am sure they have your purchase records.

Finally, another option is -- depending on what your app did -- you can try to make it a non-DSC, pure-LV app.

Hope this was helpful.

Regards,

Khalid Ansari

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.