Jump to content
Yair

"View Unread Content" does not handle multi-page threads nicely

Recommended Posts

  1. Go to the View Unread Content page.
  2. Find a thread which has multiple pages and where the oldest unread post is not in the last page.
  3. Click the link which brings you to the oldest unread post.
  4. Don't continue to the last page of thread.
  5. Reload the View Unread Content page again.
  6. The thread does not appear in the list even though you haven't read the last page yet.

I run into this sometimes when I don't notice that there's another page. When I click the link again, the thread isn't in the list, thus causing me to miss posts.

Share this post


Link to post
Share on other sites

It's actually even worse. I just had a thread disappear from the list when I haven't even read it at all.

Here's what happened:

  1. I went to the unread list.
  2. I opened some of the links in new tabs.
  3. I went to the second page of the unread list.
  4. I went back to the first page.
  5. I saw a thread () which had some new posts, but which I thought might have too many new posts.
  6. To check whether it was too long, I right clicked the OOP forum name next to the topic title and opened the forum in a new tab to see when the topic was started.
  7. At the same time, I refreshed the unread list page.
  8. When I looked at the other tab, the thread was marked as read and it no longer appeared in the unread list.

I think this happened because of what I did at step 6. Maybe any interaction with the line in the unread list causes it to be marked as read.

Share this post


Link to post
Share on other sites

According to the links you posted to the update notes last week (which I can't find at the moment), this issue was fixed in the new version. However, I just saw this happen with two threads using the exact repro steps which appear in the first post (in this specific case, these threads were the LAVA upgrade announcement and the OpenG in user.lib threads).

Share this post


Link to post
Share on other sites

I don't know what to tell ya. But in IMO, if you click on the title or the last unread link then you should just read the remaining thread. The page delimitation is just an arbitrary delineation. If you don't want to read it then don't click on the thread. What if it was just one long single page, then what part of the thread is considered unread?

In any case here's a link to the initial release notes. And the subsequent bug fix release.

If you want to post this directly to their bug tracker go here. Not sure if you can do this if you're not a customer but give it a shot.

Share this post


Link to post
Share on other sites

The division by pages may be arbitrary, but it still reflects whether I have or haven't read something. Part of the problem is also that the page links aren't prominent enough and it's easy to miss them. If the topic wouldn't be marked as read automatically, I would see it in the list even if I haven't noticed that there's another page. Personally, I would have liked it if the forums also had a feature which allowed you to mark a post as unread. The NI forums have this and I find it useful.

Before I post this on their forums, I want to be sure we actually have the latest version. That's 3.2.0, right?

Share this post


Link to post
Share on other sites

OK, they suggested that you open an official support ticket, since this seems to be something which isn't easy to reproduce (when I created a new user it didn't seem to happen with that user).

Share this post


Link to post
Share on other sites

I don't know what changed (if anything), but it seems to work fine now.

Share this post


Link to post
Share on other sites

This issue seems to have come back. Here's a description -

There's a thread with 4 new replies on page 1 and 8 new replies on page 2, for a total of 12 unread replies.

If I click the First Unread Post bullet and don't go into page 2 manually, the topic disappears from the new content list, even though I haven't actually read page 2.

If I just click the page 1 link in the new content list, the topic stays in the list until I actually go into page 2.

Share this post


Link to post
Share on other sites

For what it's worth, I've been using the dot to browse for a very long time and never had issues with getting to the right post. Based on where those links point, I don't think it could be a client-side problem, but I don't know for sure.

Share this post


Link to post
Share on other sites

The problem was not with getting to the first post (although there were times in the past where there was such a problem too). The problem was with the next page being marked as read even if you didn't go into it. As said, it currently seems to work correctly.

Share this post


Link to post
Share on other sites

Looking at it now, it's actually not working at the moment, so either I was mistaken last time or something's going on.

Share this post


Link to post
Share on other sites

At the moment it is back to working correctly. Who knows what tomorrow will bring...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.