Jump to content

vi path for asynchronuos call in labview 2013 executable


BadLuckMan
Go to solution Solved by smithd,

Recommended Posts

Hello,

sorry, but I am confused on calling a vi asynchronously in a labview executable.

I have the following diagramm (see attached image). code is working fine in the development environment

 

 

The Vi is included in my labview project.

The application builds withou an error.

 

But if I run the executable I always get error 1003 an Open VI Reference: the vi is not executable

 

I really made sure the vi has no errors.

Where is my mistake?

 

Thanks for any help,

Ralf

 

post-4175-0-06169100-1410794555_thumb.pn

Link to post
  • Solution

Do either of these help? (I have no clue why there are two, they're basically the same ;) )

http://digital.ni.com/public.nsf/allkb/410F2EC66F60F9B0862569EE006F4FA0

http://digital.ni.com/public.nsf/allkb/705C2ECA081F3C7986256C0F00559B02?OpenDocument

 

The real question I have to ask is if you need the call to be dynamic, or just asynchronous? If it does not need to be dynamic, just use a static VI reference. This will ensure app builder finds, includes, and loads the appropriate code into the exe. This is what many of the labview examples do, so take a look in the example finder (specifically the section on controlling applications programmatically, which is code for "VI server").

 

If it absolutely needs to be dynamic, then you're better off following the KB steps to set the VI in question (St1-TCP.....) as always included, specify a specific folder relative to the exe (for example ../dynamic dependencies), and use a relative path rather than the fixed path you have there.

  • Like 1
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.