Jump to content
Sign in to follow this  
rrojas

Passing Arguments To Executable VI

Recommended Posts

My apologies if this has already been address, but I couldn't find it via the search function.

I have a startup-screen VI that calls three different executables (VIs) depending on what button is pressed. My question is if it is possible to configure the executable VIs to accept a number of passed in arguments when they're called as executables.

Does something have to be done when creating a standalone application? Do the VIs have to be converted to sub-VIs with input nodes assigned, and those input nodes are then the passed in arguments to the executable form?

Thanks in advance for any help.

Share this post


Link to post
Share on other sites

Hola diyo,

here what I found from NI Support side.

and here the text.

NOTE: In LabVIEW 7.0, when you launch LabVIEW or a stand-alone application from the command line, you can pass user-defined arguments. In the command line, enter two hyphens (--) surrounded by spaces before the set of user-defined arguments. LabVIEW does not use any arguments after the two hyphens to launch labview.exe. LabVIEW passes the arguments after the two hyphens to the block diagram of the VI you launch. In the VI you launch, use the Application:Command Line Arguments property to read the user-defined command-line arguments passed when the executable launches. Visit the Upgrade Advisor (linked below) to upgrade LabVIEW.

Refer to the LabVIEW 7.0 Upgrade Notes (linked below) for more information about using command-line arguments in LabVIEW. You also can access the LabVIEW 7.0 Upgrade Notes in LabVIEW by selecting Help

Share this post


Link to post
Share on other sites
Hola diyo,

here what I found from NI Support side.

and here the text.

NOTE: In LabVIEW 7.0, when you launch LabVIEW or a stand-alone application from the command line, you can pass user-defined arguments. In the command line, enter two hyphens (--) surrounded by spaces before the set of user-defined arguments. LabVIEW does not use any arguments after the two hyphens to launch labview.exe. LabVIEW passes the arguments after the two hyphens to the block diagram of the VI you launch. In the VI you launch, use the Application:Command Line Arguments property to read the user-defined command-line arguments passed when the executable launches. Visit the Upgrade Advisor (linked below) to upgrade LabVIEW.

Refer to the LabVIEW 7.0 Upgrade Notes (linked below) for more information about using command-line arguments in LabVIEW. You also can access the LabVIEW 7.0 Upgrade Notes in LabVIEW by selecting Help

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.