Jump to content

Error When Building EXE for PDA


Wizbit

Recommended Posts

i am trying to build an exe to go onto a PDA using the Labview PDA module but when ever i have a tab container in the code i get the following error when trying to build the EXE in device mode and emualtor mode

cosm5432_ctlid missing VI or C file

if i delete the tab container i dont get any errors and it builds with no trouble and downloads onto the PDA no problems

can anyone on here shed any light on this problem

where can i find this missing file/VI i have searched the NI website but have drawn a blank

thanks in advance

Link to post

Not an answer but a suggestion, but their are two types of tab containers in Stanf=dard LV. One is from LV, the other is OS. They are found in the "Array & Cluster Controls" and the "Dialog Controls" palettes respectively. Perhaps try the other one?

Hang on! :lightbulb: Doesn't the PDA module give you a new set of controls? Are you starting from a "New PDA VI" or just building it from scratch? Perhaps this might explain it?

cheers, Alex.

Link to post

Cheers for your reply

im am using labview wiht the exeuction target set to Pocket PC 2003 device and as a result there is only one tab coniter avaliable which is in the containers pallet

i am building the VI from scratch but it has always been built in the correct execution target ie pocket PC 2003 device (not for windows execution)

i get the same error in both device and emualtor mode

Link to post

Okay sorted the problem

i had a picture logo in each page of the tab container and this was causing the error

with the pictures deleted it builds fine

when the pictures are grouped with variuos other decortions i get the errors and it will not build

if i ungroup the pictures then it will build but the picturs do not download on the the PDA

how can i get the picturs to show on the PDA exe??

Link to post
  • 2 weeks later...

How to use PDA compact flash ethernet card to connect with fieldpoint by using the PDA module labview exe files.

The question is how can I connect them both together.Answer me if you can answer my question surely.

I hope that you can help me to solve my problem.

Probably, if you have any resource which can solve my answer, plz contact me by reply this board.

Link to post
  • 2 months later...
i am trying to build an exe to go onto a PDA using the Labview PDA module but when ever i have a tab container in the code i get the following error when trying to build the EXE in device mode and emualtor mode

cosm5432_ctlid missing VI or C file

4435[/snapback]

I ran into a similar error citing the GetAttribute function. After talking to NI tech support, I suspect there's a problem with the .lsb resource file (a special compilation of the C source file that loads into a CIN). I had to devise a workaround to get an initial timestamp from a CAN PCMCIA card because the Time/Date functions don't work properly in the context of my application code, producing dates/times exactly 66 years in the future (ok, sometimes exactly 66 years and one day in the future).

If you attempt to do any DAQ with this thing be prepared for torturous time. :headbang:

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.