Jump to content
priya devi muthusamy

Combining two LabVIEW VI into one

Recommended Posts

I am trying to integrate or combine two different VI in LabVIEW.  One of the VI is responsible to measure the airflow through a USB device connected to the computer. The other VI is responsible for sound acquisition through audio jack. Since I’m quite new to this LabVIEW, I tried to copy and paste the sound acquisition block diagram into the other block diagram which measures the airflow. After the insertion of the block diagram of sound acquisition into block diagram of airflow measurement, only the sound acquisition program runs and displays sound signals. But the airflow measurement was not working and even not displaying in the graph. I don’t know how to connect the sound acquisition program with the airflow measurement.

Is it copy pasting the block diagram is possible to integrate the two VI? Is there any other way to combine the two VI?

Here I attached the two different VI, the VI for airflow measurement (STtrace) and the VI for sound acquisition (microphone setup 2_listen).

Could anyone help me to solve this problem?

Thanks.

Regards,

Priya

STtrace.vi microphone setup 2_listen.vi

Edited by priya devi muthusamy

Share this post


Link to post
Share on other sites

Hi Priya,

I cannot run one VI as there are missing subVIs in STrace.vi. I have attached a VI where I have combined the 2 block diagrams. This is not an ideal solution. A better way would be to use each VI as a subVI, then place each subVI on a calling VI. To do this you will need to create a connector pane for each of your VIs. There are plenty of online tutorials that explain how to do this. 

One last comment. This site is intended for LabVIEW advanced users. You may find more appropriate help on the ni.com web site. There is also a Facebook group (https://www.facebook.com/groups/430271233771850/) that may be helpful.

 

STRace and Mic Combined.vi

Share this post


Link to post
Share on other sites

Hi Sir, 

Good day. 

Thanks for your suggestions and advice. I could not open the attachment that you sent to me. It is stated that the file version is later than the current version. I'm using LabVIEW 2017. 

Could you please send me again the files. Sorry for the inconvenience caused. 

Thank you very much. 

Regards,

Priya

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.