Jump to content

speed , a problem


prasan

Recommended Posts

HI friends,

am interfacing with a digital oscilloscope(rs 232) and i got lv7.1.the acquisition was very slow.i tried changing the baud rate(from 9600 to something higher) in the scope and in the system but a VISA timeout error occured.is there a way to increase the speed of the acquisitoin.of course the GPIB is a better choice, but using rs232 is it still possible to increase the speed?

thankyou

Link to post

Hi Prasan:

115 kBaud through the serial port is no problem, I use that as a matter of routine?

When you say that you're setting the higher baud rate in "the system"-- it almost sounds like you are setting it in the windows control panel for the serial port. If so, try setting it from within LabView instead.

If that's not the problem, post your code if you can, we may be better able to help.

Also, keep in mind that you can cheat on the maximum length for a serial connection at lower speeds, but perhaps not at higher speeds-- but my bet is a software issue that we might be able to help on.

Best Luck, Louis

Link to post
am interfacing with a digital oscilloscope(rs 232) and i got lv7.1.the acquisition was very slow.i tried changing the baud rate(from 9600 to something higher) in the scope and in the system but a VISA timeout error occured.is there a way to increase the speed of the acquisitoin.of course the GPIB is a better choice, but using rs232 is it still possible to increase the speed?

A dumb question, but to me it sounds that you have changed the baudrate on your computer, but have you done it also on the oscilloscope?

Link to post
HI friends,

am interfacing with a digital oscilloscope(rs 232) and i got lv7.1.the acquisition was very slow.i tried changing the baud rate(from 9600 to something higher) in the scope and in the system but a VISA timeout error occured.is there a way to increase the speed of the acquisitoin.of course the GPIB is a better choice, but using rs232 is it still possible to increase the speed?

thankyou

What scope are you using? Does it have an ethernet interface?

Also, try to use binary data transfer and then convert to DBL's in the LV code, that will help the data transfer speed.

Optimize the code to avoid sending the same command repeatedly to reduce bus traffic. Without looking at the code, can't say much more; these are just some general pointers.

Neville

Link to post
Hi Prasan:

115 kBaud through the serial port is no problem, I use that as a matter of routine?

When you say that you're setting the higher baud rate in "the system"-- it almost sounds like you are setting it in the windows control panel for the serial port. If so, try setting it from within LabView instead.

If that's not the problem, post your code if you can, we may be better able to help.

Also, keep in mind that you can cheat on the maximum length for a serial connection at lower speeds, but perhaps not at higher speeds-- but my bet is a software issue that we might be able to help on.

Best Luck, Louis

Hi louis,

I have increased the baud rate of my yokogawa oscilloscope and the baud rate

through visa option of labview to 57600 from 9600, but there is no appreciable

change in the speed of the data acquisition.I am sending my vi , please suggest the

required changes to be done.

What scope are you using? Does it have an ethernet interface?

Also, try to use binary data transfer and then convert to DBL's in the LV code, that will help the data transfer speed.

Optimize the code to avoid sending the same command repeatedly to reduce bus traffic. Without looking at the code, can't say much more; these are just some general pointers.

Neville

hi Neville,

I have increased the baud rate of my yokogawa oscilloscope and the baud rate

through visa option of labview to 57600 from 9600, but there is no appreciable

change in the speed of the data acquisition.I am sending my vi , please suggest the

required changes to be done

What scope are you using? Does it have an ethernet interface?

Also, try to use binary data transfer and then convert to DBL's in the LV code, that will help the data transfer speed.

Optimize the code to avoid sending the same command repeatedly to reduce bus traffic. Without looking at the code, can't say much more; these are just some general pointers.

Neville

hi Neville,

I have increased the baud rate of my yokogawa oscilloscope and the baud rate

through visa option of labview to 57600 from 9600, but there is no appreciable

change in the speed of the data acquisition.I am sending my vi , please suggest the

required changes to be done

Download File:post-5784-1156485685.vi

Download File:post-5784-1156485970.vi

Download File:post-5784-1156486221.vi

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.