Jump to content

Neville D

Members
  • Content Count

    752
  • Joined

  • Last visited

  • Days Won

    2

Everything posted by Neville D

  1. Rounding error on the coefficients in FPGA?
  2. Do you have all the DAQmx drivers and such loaded? Check and make sure you have all drivers on your new system the same as your old system.
  3. Are you using LabVIEW RT on the PXI chassis? Do you have some sort of plugin architecture where the built exe does not have the required plugin in the right spot?
  4. AlexA, I am not sure what is going on with your system, but we use fpga's with cRIO all the time with the fpga part of the code being the most reliable. We typically open a reference to the fpga bit file and share that in a global across all the parallel loops that need to access the fpga (so only one reference is opened). We never close the reference unless the real-time code is stopped, which in our case is never. Are you getting any errors with your system? Opening multiple references (fpga or otherwise) in a loop continuously? "Unresponsive after a while" points to some
  5. You could use Data Value References when dealing with large blocks of data. Thats what they were designed for.
  6. As you found out, all front panel properties don't work exactly the same in LV-RT. I don't think opening the front panel property will work on RT, since VI's don't really have front panels in that environment. If you look at the help for various properties, there is a chart that shows whether that property will work in RT or executable form and whether they are read only or read/write. You might have to write a VI running on a PC that accesses the data points from RT and plots whatever graph you need there.
  7. A quick picture of your code or an upload of the relevant VI would help us understand what you mean.
  8. Send me a pm if you would like a pdf of the presentation.
  9. Hi everyone, I will be presenting TS1360: "Implementing an Efficient Moving Average Filter in LabVIEW FPGA" on Thursday 1-2pm. Room 16B. These techniques are relevant for developing any sort of code on the FPGA, not necessarily filters. Many of the findings are a bit counter-intuitive for someone used to developing regular LabVIEW code or even Real-Time LabVIEW code. Hope to see some of you there or bump into you in the corridors of the Convention Centre! Cheers, Neville.
  10. Click on My Computer in your Project, and then select New>Targets and Devices.
  11. Hi Erik, try to troubleshoot which property node the error is coming from in your code. It is usually a property node with multiple inputs, and the first input (argument 1) is invalid. I suspect it might be the VISA serial configure; if I remember right, it has a property node with multiple inputs. Maybe the VISA resource string is empty? corrupted? incorrect? invalid? Check all the inputs going into the VI; one of them is not what is expected. In future, attach the VI and the complete error message to help others save time when helping you. Neville.
  12. I would suggest going with a fanless industrial PC with either compactflash or SSD instead of a hard drive if you want reliable 24/7 operation. Fully enclosed (no vents). Use heatsinks as directed for mounting. There are dime a dozen manufacturers out there. Be sure to check the temperature and vibration specs on the units. Another potential failure point for industrial systems are cables and connectors. Make sure connectors are lockable type or have some sort of attachment to prevent them coming loose with vibration. Its things like these that differentiate a $500 desktop PC from a
  13. You should be able to run everything on a PC configured as an RT target. Just make sure that the equivalent PCI versions of the cards you need are supported under LabVIEW RT. If they are, then you should be good to go. The biggest issue with using desktop PC's with LV RT is that the Ethernet chipset may not be supported under LV-RT. Check this with the NI utility (there is a utility you can load onto a USB stick to test whether your PC will work with LV RT) or on their website documentation about the various chipsets supported with each version of LVRT, and you should be OK. Neville
  14. What hardware modules are you using? Do they support the high data rate you desire? Try slowing down the sample rate to a very low value to see if the error goes away. Neville.
  15. Are you measuring a constant voltage?
  16. Hard to understand your question without a picture. Is the NSV a boolean? enum typedef? Is the default value fail? Maybe it never gets updated? Is it timing out? Add a boolean to the TimedOut? terminal of the NSV. Neville.
  17. Are you using flourescent lighting in your lab? The greenish tint is probably because you need to adjust white balance on the camera. Use a white sheet of paper in front of the camera and adjust white balance. In the past, I have used Fujinon and Tamron Machine vision lenses. Great quality, high resolution, large aperture, rugged, and with locking screws on iris and focus rings. http://www.fujifilmusa.com/products/optical_devices/machine-vision/ I found AudioVideoSupply out of LA to have good service and support. http://www.avsupply.com/computar-lenses.php The vignett
  18. Hi Everyone, Does anyone have any recommendations for using a USB-based security dongle with a LabVIEW 2011 application? This would be for a Windows 7 application. Ease of use with LabVIEW? Cool features? Any negatives? Thanks, Neville.
  19. Also make sure whatever camera you buy will work with IMAQ vision assistant. If its a webcam it may not work with IMAQ. Neville.
  20. Older versions of NI Vision had a well written PDF "Vision concepts manual", that explained the algorithms, their pros and cons etc. Newer versions have that removed, and replaced by a painful to read .chm (help) file. It also seems to be broken up into a number of different files. On your PC, under: NI\Vision\Documentation\ NIVisionConcepts.chm, and NIVisionLVBasics.chm. Search through those. You might also do a search on the NI site for some additional presentations by the Vision R&D team that sometimes go in-depth into the algorithms behind some of the functions. I know there wa
  21. Sorry, just saw this. I don't remember now, but I checked the CRC generation code and the NI version didn't exactly conform to the ModBUS spec document (Pg 14 & Pg 39): http://www.modbus.org/docs/Modbus_over_serial_line_V1_02.pdf Bottom line was: Steve Brooks' version worked with a ModBUS device I was using, and the NI version didn't.
  22. Just took a look at your code. Some comments (though they may not relate to the strange behaviour you are experiencing): 1 There is no VISA Close Session. If you run this code a number of times, I am not sure it will behave stably. Add VISA close at the end. This will also allow you to access that serial port with something like HyperTerminal if desired. 2 Usually Serial reads are accomplished by polling "Bytes at Serial Port" in a reasonably slow loop and then reading the required number of bytes with the VISA Read. See attached. 3 I am not sure why you have a VISA Asynchronous Wr
  23. Can you right-click on the bottom of the VI and select "My Computer"? Where is the VI in your project? Under My Computer or on an RT target?
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.