Jump to content
Sign in to follow this  
Mellberg

Combo Box bugs (2)

Recommended Posts

Hi Folks,

Just want to report two LV-bugs I found. The bugs are reported to NI.

First, if a combo box is set to 'allow undefined strings', you can't write 'ABBA' if 'abba' already exists among the 'strings []', i.e. a pull down-menu item.

Second, if a combo box string-item (one of the pull down-menu items) contains a string that is 276 chars or more in length, this can either cause LV to pop up a 'crash' dialog or crash hard without any dialog.

These two bugs exists from, at least 7.0 to 8.2, as far as I know.

//Mellberg

Share this post


Link to post
Share on other sites

One other strange thing I just found out:

It's not possible to enter a comma in a combo box???

Is there a good reason for this??

VDB

Share this post


Link to post
Share on other sites

QUOTE(VDB @ Apr 20 2007, 04:19 PM)

It's not possible to enter a comma in a combo box???

Is this in 8.0?

I just tried it in versions both before and after 8.0 and I have no problem in typing a comma into a combo box.

Can you upload an example VI with detailed instructions?

Share this post


Link to post
Share on other sites

QUOTE(yen @ Apr 21 2007, 09:20 PM)

Is this in 8.0?

I just tried it in versions both before and after 8.0 and I have no problem in typing a comma into a combo box.

Can you upload an example VI with detailed instructions?

It's 8.2. Start LabVIEW, new VI, create a combobox (doesn't matter if modern, classic or system) and try to type a comma.

Pasting a comma works. Maybe it's because of the German Windows...

VDB

Share this post


Link to post
Share on other sites

QUOTE(VDB @ Apr 23 2007, 08:56 AM)

It's 8.2. Start LabVIEW, new VI, create a combobox (doesn't matter if modern, classic or system) and try to type a comma.

Pasting a comma works. Maybe it's because of the German Windows...

VDB

Hi,

I can reproduce this on WinXP (English).

Defining the list of allowable values works with commas, but entering commas into the Combo box don't.

I think you should report this to NI as a separate bug, and maybe start a new bug thread here at LAVA.

/J

Share this post


Link to post
Share on other sites

QUOTE(VDB @ Apr 23 2007, 09:56 AM)

It's 8.2. Start LabVIEW, new VI, create a combobox (doesn't matter if modern, classic or system) and try to type a comma.

Pasting a comma works. Maybe it's because of the German Windows...

Works fine in a version which is above 8.0, but is not 8.2 (or 8.2.1), so either this was fixed, or it could be an issue with locale settings. You could try setting your OS settings (Control Panel>>Regional and Language Options) to use the period instead of the comma and see if that changes it.

Share this post


Link to post
Share on other sites

QUOTE(yen @ Apr 23 2007, 09:57 PM)

Works fine in a version which is above 8.0, but is not 8.2 (or 8.2.1), so either this was fixed, or it could be an issue with locale settings. You could try setting your OS settings (Control Panel>>Regional and Language Options) to use the period instead of the comma and see if that changes it.

The behavior stays the same, I guess it's a bug..

VDB

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.