Jump to content
Black Pearl

lv_new_vi.vi ConPane

Recommended Posts

I'm trying to hijack the CTRL+N shortcut to start with a template vi instead of a blank vi. I guess my problem is, that I have the wrong ConPane for the lv_new_vi.vi . In some old threads I found discussions about it, but there was no code to extract the ConPane (maybe due to the server crash).

Felix

Share this post


Link to post
Share on other sites

I posted a VI which does this in this thread, but as you said, the attachments are missing. You can use the report to a moderator button on the post to ask the moderator to find the function. I also posted a document in that thread (reply 21) which shows the various plugin overrides you can use.

I can't look at either of them at the moment, but if memory serves, the conpane for the VI is the 4-2-2-4 pane with an I32 output wired to the top-right corner. I believe it should be 1 if you want to cancel the creation of a new VI or 0 if you want to allow it (or the other way around, or it might have been 1 and 2).

  • Like 1

Share this post


Link to post
Share on other sites

Got it!

The name of the control must be 'return value'. Guess they use GetValue property somewhere.

Felix

Edited by Black Pearl

Share this post


Link to post
Share on other sites

You're right. I didn't notice that now because I was actually looking at a subVI which had the output labeled something like "create new VI?".

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.