Jump to content

Application startup takes several minutes

Recommended Posts

Hi LAVA's,

I need your help, please. I have made an application for a customer in LV2009.

On my pc (VISTA 32bit) and on a Virtual machine (XP and similar specs as customer pc) it takes 10s to startup.

On my customer's PC it takes about 5 minutes to start. :wacko::frusty:

Some info:

The application has a plug-in architecture.

The 'testengine' is a string based statemachine.

Plugins are by value classes that are loaded depending on the chosen test Sequence

In the testengine, I use 1 class to read a config file and I use VISA to read a serial port (barcode-scanner)

The tests are as told above By Value classes. The tests'method 'execute' is a string based state machine that uses 4 By ref classes to read sensors and adjust valves with DAQmx.

A testSequence exists of about 6 steps so no big tests.

Once the application is started all works fine. No memory leaks (500MB of spare memory) , no CPU that is stuck at 100% etc etc.

Info on the pc that runs the application:

panasonic CF-19 Toughbook - intel centrino duo 1GHz - XP 2002 SP2 but vista capable - 1GB RAM - 3GB free diskspace.

I've made a few test vi's and made an exe of them:

test1: while loop with event structure and a stop button. Exe opens instantly

test2: Same as above but I read a DAQ task that is in my project. Exe opens instantly.

So... slow startup is not due to loading LV runtime or DAQ mx.

The customers PC has a very strict security policy. (i can't even change a key in an ini-file in the program files/... folders.):blink:

Can someone help me to solve this issue.

Thanks in advance.



Just noticed a similar post here.

but I do not use a .NET picture control

Edited by Wim
Link to comment

Hi Wim,

1 GHz doesn't sound like that much nowadays.

When are the plugins loaded?

Can they be the cause of the long load time?

Have you tried disconnecting any network peripheral? (or connecting to any)

Is the swap file being used during the starup of your application?


  • Like 1
Link to comment

Hi Ton,

after meeting at NI Days NL, we meet again at Lava ;)

I agree that 1 GHz isn't that much.

Plugins are loaded at start of a test so not at startup of the application. So they are not the reason for the long loading time.

The PC is connected to the network. I asked my customer to try starting the application with the WiFi connection turned off. Hopefully I know the result tomorrow.

But in the end i need this connection to store reports on a network drive.

Maybe a stupid question, but how can I check if the swap-file is used ?

Some more info:

If i start the app, it appears almost instantly on the windows taskbar. In the taskmanager it shows some CPU activity and allocates some memory. Then CPU activity goes to zero. After a few minutes, CPU activity goes to 25% for a few seconds and then the frontpanel opens and evrything runs smoothly (also the plugins)

I hope this extra info helps.



Asbo: you posted while I was typing :shifty:

The first thing i do in the application is create a logfile and this happens a fraction of a second before the frontpanel opens. So it is not the 'initialisation'code.

Edited by Wim
Link to comment

I had this same problem and was never able to figure it out. It was like the computer had a vendetta against any exe built using LabVIEW. Only happened on a few computers and the only way to fix was to rebuild the computer from scratch. I questioned our corporate antivirus filters, but was unsuccessful at figuring out where the problem lays.

The frustrating thing was that these were exe's that I had used for a long time and now all of the sudden are loading very slow on particular computers but all other applications worked fine. Maybe because it isn't an approved application?

Hope you find your answer because I'd like to know too.


  • Like 1
Link to comment

Starting in safe mode is a good test.

Will try it next thursday when I'm with the customer.

They are also running a very old version of Symantec anti-virus. Could this be a showstopper ? Sadly I don't have enough rights on the pc to turn it off :(

Link to comment

Just received some more info from my customer.

Turning off the WiFi connection gives a startup time of less then a minute....

I used to have that problem in the development environment. No network - Quick loads. Network - it would hang for a looong time on startup.

It turns out there was a link to a vi that no longer existed in my project. For some reason LV went hunting for it even tho I didn't use it.

I'm not sure if this will help with a built application, but it might give you a place to start looking...

  • Like 1
Link to comment

Symantec could certainly increase the load time, but I would think that the delay would be before the application even appear on the taskbar (because AV will block an access request and scan it, assuming it has "real-time protection"). Definitely worth trying, though.

Consider getting acquainted with WireShark and bring it with you - set it up to watch the WiFi connection and see what's going on.

Link to comment


already thanks for all the help. But untill now i didn't have a chance to do some testing. Thursday is D-day.... hopefully I can find the problem.

One more question: in the config file of my exe i see the following key: server.ole.enabled=True

If I put it on false, all seems to work on my pc.

Can anyone tell what that key stands for ?

I found this on the LabVIEW Wiki: Description: Enable the local LabVIEW OLE/ActiveX server

I don't need active x (it is disabled in my build specifications) but this key is always set to TRUE in the ini-file



Link to comment

I am actually having a very similar problem. The common piece for me is Windows 7. The same application will launch in seconds on XP and Vista, in either 32, or 64bit. But on Windows 7 (either version) it behaves just like the OP says: Shows up on taskbar immediately, no CPU or drive use for a LONG time, then it starts. Also, whenever I access a windows function, the first use take forever. For example, launching the Windows folder browser, or reading the version information for my executable. I can't figure out what it is. Also, not every LabVIEW executable starts slowly like that. Some start right away. These machines are fresh installs with no networking, no anti-virus, no firewall, nothing (they are isolated in a lab). And they are powerhouse machines (6-core, 6 GB RAM, 5TB of HDD space). The same program starts right up on a dual core system with 2GB of RAM.

Link to comment

Hi all,

I went to my customer today to do some tests and guess what ... problem solved laugh.gif



- pc had errors in the eventviewer:

Event Type: Error // Event Source: crypt32 // Event Category: None // Event ID: 8 //

Description: Failed auto update retrieval of third-party root list sequence number from: <http://www.download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/authrootseq.txt> with error: This network connection does not exist.

For more information, see Help and Support Center at http://go.microsoft....ink/events.asp.

The admin was available so he did an update of this. But after logging in as the operator, the problem was still the same.

Then we found a solution here. We made the operators local admin and disabled the auto update of the root certificate for XP. (local admin was needed because of the campanies security policy)

Startup time after this: 15secondsthumbup1.gif

Thank you all for the info and hints to solve the problem. Maybe this solution can help some of you.



  • Like 2
Link to comment
  • 2 weeks later...

Hello LAVA forum members,

In our department at Utrecht University we have a similar problem with applications built in LabVIEW 2009.

The application that shows the problem can even be reduced to a very simple one: Just add two numbers. The exefile starts in a few seconds when on a local computer. When we run it on a server (as our students are doing) it takes 30 seconds or more. Exactly the same program build in LabVIEW 8.6 starts in both cases in a few seconds. All our applications are having this startup delay in Lv 2009 compared to 8.6. So up to now no LabVIEW 2009 in our students laboratory. Anybody any idea?

Jan Kuperus

Link to comment

Hi Jan,

maybe you can try the same things that I did.

First try to start an LV executable with the network diconnected. If this helps then you can check the items I mentioned in an earlier post.

Good luck.


Link to comment

I looked into the network connection issue, but in my case, the computer isn't connected to a network. Maybe my problem is different since the applications start fine in LV2009; it's only on Windows 7 machines that the long start time occurs. I also looked into the issues the OP resolved, but that wasn't happening on our machines.

Link to comment

I looked into the network connection issue, but in my case, the computer isn't connected to a network. Maybe my problem is different since the applications start fine in LV2009; it's only on Windows 7 machines that the long start time occurs. I also looked into the issues the OP resolved, but that wasn't happening on our machines.

Since the app. is not on a network you might want to consider disabling a virus scanner and firewall to see if one of those helps. It might help to allow the app (or disallow) to connect to the network (even localhost).


Link to comment

Since the app. is not on a network you might want to consider disabling a virus scanner and firewall to see if one of those helps. It might help to allow the app (or disallow) to connect to the network (even localhost).


The computer doesn't have a virus scanner and all of the windows defender options are off. The application has all the access permissions I can give it. I'll keep looking into it though. I'll make some test applications to see if there's a way to not have these issues. It's not just startup that's slow on windows 7 either. I can launch an explorer window with no problem, but using the folder browser will hang up the program for several seconds. Are there certain OS functions that the run-time engine calls before the front panel is loaded that windows is hanging up on? Does LabVIEW run any code before the front panel is loaded? If not, then why wouldn't the panel load, and then pause. If it does run some code first, at what point does the front panel show up? I don't know what happens in the OS when you launch an application, but I assume there is some kind of allocation request, maybe access to the graphics system, or calling the "application directory" function. I will try a few things and pass the results along.

Link to comment
  • 2 weeks later...

My problem is just the other way. On a local machine our applications build with Lv2009 run fine (connected to the network or not). When started on the same machine but with the exe-file on the network server I can drink a cup of coffee. The same programs in Lv861 are running withoud delay from the server. NI engineers say they can not reproduce the problem.

We tried Wim's solution without succes. Anybody an idea?

Link to comment
  • 2 years later...


I had been having this problem for a while too, but I finally fixed it yesterday. I installed Wireshark to discover that my application was constantly sending Internet requests to Verisign. I looked the request up on Google and it appears that it is a .Net known bug that leads to the application verifying automatically the signature of .NET components by Authenticode. This leads to networks timeouts and long delays when launching the application when not connected to the Internet, but having an active network connection. I found the fix on ni.com.

Here is the link:


I guest there was nothing wrong with my program after all!


  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.