Jump to content
Dustin

OpenG bug report: Array to Array of VData loses cluster element names when array of clusters is used and array is empty

Recommended Posts

So I'm not sure if this is the proper way to report an OpenG bug, but it seems like a good place to start.

 

The problem is the OpenG VI "Array to Array of VData" loses cluster element names when an array of clusters is used and the array is empty.

 

I've isolated the problem to the NI VI "Variant to Data" conversion that converts the array contained in a single variant to an array of variants.  I'm frankly not sure what a suitable replacement should be but I figure that reporting the problem is a good first step.

 

 

 

 


post-51778-0-93359800-1398978286.png

  • Like 1

Share this post


Link to post
Share on other sites

Hi Dustin. Thanks for reporting this. I think I get what you're saying. Could you attach a small example VI that demonstrates the problem?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Dustin
      I've run into an interesting problem using the Open G variant library.  When trying to extract a list of cluster element names from a cluster in an empty array of clusters in a cluster itself, I get the following error from the Open G "Get Cluster Element Names VI":
       
       
       
      An example VI showing the problem is attached.
       
      At first I thought the problem was due to the fact the array is empty, but asking for cluster names of an empty array of clusters that is not in a larger cluster completes without error.
       
      Any thoughts on the cause or solution to this problem?
       
      empty array of clusters problem.vi

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.