Jump to content

Resize handles disappear

Ed Dickens

Recommended Posts

I've had this problem come up on me several times while developing my applications in both 7.0 and 7.1.

The resize handles disappear from all resizable objects on both the front panel and block diagram. Sometimes dropping a new function (like Scan from String) onto the diagram and deleting it will bring them back, but not always.

I've recently noticed that whenever this happens, there is what appears to be a grab handle at the 0,0 coordinate on the front panel of any open VI. I

Link to comment

Here's NIs official response to the report. Pretty much as I expected, but thought it would be worth at least reporting it to them.

To answer your question:

I agree, this is very odd behavior!  I have never encountered or heard of this behavior before.  Is it VI-specific or LabVIEW-specific?  To clarify, does it happen on certain VIs and not on others, or is this a problem that is persistent with any VI in LabVIEW?  I'll assume that it is a LabVIEW environment issue unless you specify otherwise.  What I would suggest to you is:

1)  First, try to Repair LabVIEW.  You can achieve this by going to Add/Remove Programs->National Instruments Software->Change.  Select LabVIEW

7.1 and click Repair.  Check to see if this solves the issue.  If not,

2)  Try a Uninstall/Reinstall of LabVIEW.  This usually solves any issues not taken care of by Repairing LabVIEW.

Hopefully one of these methods will take care of the behavior that you are seeing.  It sounds like maybe a part of LabVIEW has become corrupt, and when this occurs it is nearly impossible to try and "debug" the situation.

Hopefully this will get you up and running, Ed!  Please let me know if these two methods take care of the behavior or not.  Take care and good luck!!!

And a followup answer after I gave a few more details.
Well, if nothing else, it's good to know that we can restart LabVIEW to "fix" the problem.  I polled a bunch of people here in the office to see if anybody had heard of or experienced this behavior before and the results were negative.  I see the two references that you linked below, but its near impossible to troubleshoot non-reproducible behavior.  I'm interested to see if a complete uninstall/reinstall of LabVIEW will eliminate this behavior.  Usually situations like this are fixed by a clean install, so I feel pretty confident that this will take care of it!

The two references he mentions are two links to two other reports of this same problem. One from the NI forums and one from Info-LabVIEW.

NI Forum reference

Info-LabVIEW reference


Link to comment

This has happened to me at least five times over the past year (undo - redo always fixed it). I reboot win2k every 4-6 weeks and restart LV every two weeks. I can not reproduce it but I think the problem gets cleared after a LV restart.

Link to comment

An uninstall/reinstall do not resolve the problem. Due to other problems (with my computer) I had to reinstall LV 2! times and still get this odd behaviour. One was a clean install from a freshly installed Win.

My computer is shut down every evening. An undo/redo also solves the problem.

Last recent (yesterday) behaviour: I wired a Unbundle By Name and got a relatively long element. I changed to a shorter one and... bingo... the handles stayed where they originally were... and the Unbundle was unusable.


p.s. Since I have no SSP, Ed please feel free to forward it to NI, Thanks.

Link to comment

Thanks Didier, I will pass that along.

One thing I'd like to find out is are others seeing the block at the 0,0 coordinate as I've shown in the images in the original posting?

So, if you do have this happen, scroll the panel to the 0,0 point and see if that block is there and report it here.



Link to comment
One thing I'd like to find out is are others seeing the block at the 0,0 coordinate as I've shown in the images in the original posting?


That is what I usually see. The effect I described yesterday is something new, never seen before. But I was in a hurry (was in a meeting), so I did not a print-screen :( .

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.