Jump to content

Wifi issues when running with parallels

Recommended Posts

I am currently running Labview on my mac using parallels and a version of windows 10. After installing Labview on the windows virtual machine the wifi no longer worked in the virtual machine. The mac portion of the computer could still connect to the internet without any issue but the windows running on parallels was no longer able to connect. Somehow I was able to resolve the issue with connecting to the internet in windows, but it is saying it is only connecting via ethernet and does not show any wireless networks. I'm attempting connect to a myRIO via wifi but since the windows refuses to show any wireless networking options I am unable to connect. I'm wondering if installing Labview somehow messed up any wireless drivers in windows.  

Ive also tried all the different kinds of bridged networking types and they do not solve the issue

Edited by engineeringstudenthelp
Link to comment

I would do the following:

Setup my Parallels VM to use Wi-FI from MAC in bridged mode

Make sure my Windows VM network adapter config is correct to reach the myRIO

Ping the myRIO - if no response then you have a network config issue

If still not working I would shut down the VM, restart the Mac and then start the VM.

Ping the myRIO - you should definitely get a response


(One other thought, you MAY also have a Windows Firewall issue, can retry with Firewall off if all of these steps fail but I don't think you should need to do that)

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By Chris
      I used a USB-6001 DAQ unit for a Quiz Buzzer game that worked down to an accuracy of 1ms - great no problems .
      However having to wire up all the buzzers (up to 13) each time was becoming a pain and it doesn't scale very well, so I was looking at using tablets (probably Android based) to transmit over WiFi a virtual buzzer press.  But then of course you have all the latencies etc. of the TCP/IP packets to contend with.
      I was wondering if it was possible to use the IEEE 1588-2008 standard (Precision time protocol over ethernet) to get similar accuracies - even up to about 20ms accuracy would be OK over a standard WiFi connection?
      I was thinking you can send a master clock signal (eg. using someting like the JJ Control uS Clock) from a central LabVIEW server application to all the Clients (Tablets) up to 10 times per second as per the standard to keep clocks synchronised.
      I had a look, but couldn't find a IEEE 1588-2008 LabVIEW toolkit - is there one available?
      If not is there a simple way of achieving this?
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.