Jump to content

SIGSEGV in Import Shared Library


Recommended Posts

I'm getting immediate segmentation faults when trying to run the import .so wizard, on an ubuntu 20 machine where I have installed LV14, 19, 2021 and 2023 (up to date). All versions of LV appear to behave normally during my usual workflow, but now crash immediately after choosing Tools/Import Shared Library, and displaying the first window of the wizard. I tried to launch LV through ddd, and the only hint I'm able to get is that there is a segmentation fault in early /usr/local/natinst/LabVIEW-XX/resource/headerparser.so.

I've tried different versions, running LV as root, clearing cache at no avail. Only a couple of times I was able to go through the dialogs the wizard down to the point of starting the compilation (after choosing .so, .h, include dir, functions to wrap, arg types), but since then not again. Any idea about what could be wrong and how could I debug further?

Link to comment

For the record (self note?)

Narrowing down with some more use of ddd. It seems that there is a bug in 2023Q3 at the stage of the generation of the library. There is a segmentation fault in

HEADER_PMSave () from /usr/local/natinst/LabVIEW-2023-64/resource/headerparser.so

apparently when calling

xercesc_3_2::IconvGNULCPTranscoder::transcode(char const*, char16_t*, unsigned long, xercesc_3_2::MemoryManager*) () from /usr/local/natinst/LabVIEW-2023-64/resource/libnixerces.so.3

which produces an empty file /home/xxxx/natinst/LabVIEW\ Data/Shared\ Library/HeaderParserResult.xml. Once that empty file is created, any other version of labview will segfault when attempting to start the Import wizard. Removing that file allows earlier version of LV to complete the import process.

Now if I would understand in which status we are under our SSP, Emerson, SAS transition or whatever I could report it as a bug, and get perhaps a CAR...


Btw, when the empty xml is present, the crash occurs, in 2023Q3, at the 12th call of

xercesc_3_2::XMLString::transcode(char16_t const*, xercesc_3_2::MemoryManager*) () from /usr/local/natinst/LabVIEW-2023-64/resource/libnixerces.so.3


HEADER_ProjectManagementInitialize () from /usr/local/natinst/LabVIEW-2023-64/resource/headerparser.so

Link to comment

Could someone kindly check and confirm this bug on some other installation? I'm having hard time convincing the correspondent Technical_Support_Engineer_NI_is_now_part_of_Emerson that the bug is reproducible (it is for me on two different Ubuntu 20.04).

Subbug 1: (happens with any LV version I tried)

cd ~/natinst/LabVIEW\ Data/Shared\ Library/
rm HeaderParserResult.xml
touch HeaderParserResult.xml
labview64 --> select Tools/Import/Shared Library (.so) --> SIGSEGV

Subbug 2: (happens with LV2023Q3f0 and f1)

  • copy the attached file in ~/natinst/LabVIEW\ Data/Shared\ Library/ (to save you from doing the process from scratch)
  • mkdir /tmp/LVimport
  • labview64 --> select Tools/Import/Shared Library (.so) --> Update VIs --> Next --> Next --> ... --> SIGSEGV


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.