Jump to content

JackDunaway

Members
  • Posts

    364
  • Joined

  • Last visited

  • Days Won

    39

Everything posted by JackDunaway

  1. Hey Mike, this weekend project i worked on a while ago may give you some ideas -- https://bitly.com/CognoscentUI
  2. Choices, choices.... Dash (http://drivewithdash.com/) -- led by a familiar face who's no stranger to LabVIEW!
  3. The only thing that jumps out is it looks like you're using LV2010 -- hopefully this issue would not bite you in later versions. Otherwise, it feels like a bug.
  4. The most real challenge has been simply interrupted cognition and lost time waiting for things to happen -- connections over RDP are oftentimes klunky -- it feels like I'm always switching between engineering and devops mindsets, and this thread swapping is inefficient -- these are purely anecdotal issues, YMMV. My best advice is to jump right in with what you're trying to do, and post specific issues as you run into them. (Also, it sounds like you're making the good choice to develop locally, then deploy the executable remotely. After walking down the path of attempting to develop remotely, this was far too burdensome due to the latency of RDP -- I could never get into 'the groove')
  5. Replace your format specifier with the one linked by Philip Brooks for ISO-8601 and XKCD compliance. http://xkcd.com/1179/
  6. The problem domain of deploying to and developing on a remote Server instance has challenges and nuances not present on desktops and local VMs; yet I have not run into inherent problems or incompatibilities between LabVIEW and Windows Server 2012 (or 2008, when i used that). Are you concerned about something in particular?
  7. Well, it depends. At what speed were you, the observer, traveling with respect to the execution speed of the block diagram?
  8. Well, it's kinda not a new string... it's just a noncontiguous substring. (Can a substring be defined as 'noncontiguous'? Perhaps, no, and what i desire is impossible.) Wow, thanks for going out of your way to recreate! Sorry snippets broke for you That is basically the way I'm solving the problem right now; with extra syntax. The prime motivation for finding a *purely* regex solution is to generalize this problem -- consider wanting to remove adjectives from both nouns: The fox jumped over the dog This general solution more closely matches my problem domain. (This thread presents the simplest form of the problem, since I can't even figure that out; or if the desired solution is even possible!)
  9. That got me excited... but it's not quite right. The whole match is still just the submatch, because the lookarounds are zero-width. Virtual +50 bounty for the regex that makes the green light come on in the following test harness:
  10. It would be helpful to have access to the text that was replaced. It is easy enough to create a re-use VI that does this; I'm just curious if the ability already exists.
  11. Well, simply finding a submatch is the easy part ;-) What I'm really interested in doing is returning the original input string as the match, minus the submatch. Figure this out, and then we can fly around on vines saving days :-)
  12. OK; so, the consensus is that there does not exist a single regex to solve this? (I was really hoping to learn of a solution that could be achieved purely by the regex engine.) The best name I can come up with for what I'm trying to do is submatch extraction, where the whole match depends on matching directives before and after the submatch, yet excludes the submatch like this:
  13. How can I exclude a variable-width, inner part from a regex match? For instance, given the three following inputs: The quick brown fox jumped over the lazy dog The quick brown fox jumped over the sleepy dog The quick brown fox jumped over the hotdog I want to match the following: The quick brown fox jumped over the dog I have investigated negative lookarounds, but since these are zero-width assertions, I can't easily figure out how to include additional regex directives on *both sides* of the lookaround. Is this problem relegated to the use of Search and Replace String configured for regex matching, or can this be achieved with a simple regex match? Here's a screenshot of one of my naïve attempts using RegexPal; a successful attempt would also show "dog" highlighted as part of the match, but excluding the dog modifier. At least it doesn't match 'frog' :-)
  14. Neat! I see a prime candidate for Coerce to Type in there; this, and removing the decrement by pulling the ENUM output before the increment could tidy up that last bit of syntax.
  15. On-board diagnostics linked to your smartphone -- the future is here. I'm sensing a mid-summer Christmas present this year... http://www.automatic.com/
  16. Turn your volume on for this one; but make sure it's at 5%!!
  17. Rolf; thank you for this reply. To follow up, I have received some ideas through another channel on how to solve this issue; I will report back after testing the suggestions. (Having just concluded the CLA Summit, I will be back on this project soon). Brief spoiler -- this channel's suggestions are not unlike yours.
  18. (Replace the lowercase actor below with process or subsystem or service... it's more general than an Actor Framework Actor.) I had a brief offline conversation about this topic the other day about the semantic difference between a command and a request sent to an actor. An actor receiving requests is generally in charge of its health and destiny; an actor sent commands is subject to DoS attacks or other hazards from external sources, whether incidental or malicious. As Dak mentions, separating incoming messages from the job queue is a great implementation for receiving requests (I owe a lot of my understanding and respect for this concept to the JKI State Machine). The visual below represents an actor (the traffic intersection) and its response to individual messages from four distinct non-owning-but-using actors (the incoming lanes) defining their own concepts of priority (drivers with their own agenda). Were this intersection handling incoming requests rather than commands, it performs its job more effectively (by coordinating order, rate, and even batch-ness by aggregating requests to provide efficiency) and reduces undesirable interaction between the four independent actors. (Finally, I don't assert requests sent to actors are universally better than commands, since they each have merits in different problem domains; just acknowledging the existence of this concept, especially when chain-of-command and ownership does not naturally exist.) Originally from: http://chivethethrottle.files.wordpress.com/2013/01/random-t-01_18_13-920-55.jpg
  19. Can you explain this one? And for clarity; this is for the .hgignore checked into your repo root or the global? Ignoring the ignore file.... I can see where this is desirable, but not necessarily the norm. I'm not well-versed enough in the FPGA domain to make a decision -- but would you say for the same reason as DLLs etc, it may be desirable to check this into SCC if it's part of an RT distro, and therefore not a good candidate for the baseline .gitignore?
  20. Thanks for linking conversations to substantiate! Here's commentary: For the same reason I would not include DLL and other library exclusions from gitignore, I would not add an exclusion for ZIP, VIP, and OGP (since they can be dependencies as part of a distributable application -- e.g., they can be but are not necessarily 'end products'). And as for /built*$ and /build*$, the same conversation applies from Shaun's suggestions -- these are better placed in individual developer's Global ignore. But you're onto something with the .viobj -- are there instances where this can end up in the source directory?? Or is this a throwback to the early days when there was discussion if viobj would be stored locally with the source or in a global cache (spoiler: the global cache idea won out -- *i think* -- yet if there remain some cases where viobj is stored in the source dir, that's a great reason to include viobj in the default gitignore)
  21. Yes; and this question prompted further digging and inspection of other gitignores in the repo, and the README.md has this information: "Global gitignores (OS-specific, editor-specific) should go into the Global/ directory." OS-specific includes .DS_Store and Thumbs.db, and something like */build/* would be considered editor-specific. So; for now, we're back to the original with just .aliases and .lvlps. For those using Hg: what do your .hgignore's look like?
  22. Would you suggest for this reason removing Probes and Menu Palettes from the LVClass definition? These are precedences of conveniences/facilities to use the class effectively, yet do not define the operation of the class. Unit Test usage in this context could be considered an extension to documentation. (And: I'm not necessarily seriously supporting making Unit Tests a first class feature of the class definition; it was more, just throwing it out there to consider and iterate) If the Unit Test is a member of the class, what's to prevent white box testing with scripting? That's a form of inspection; sometimes better than the human eye (e.g., for catching an error wire that runs under a method rather than connected to its I/O). Unit test here could be used interchangeably with VI Analyzer test. I won't disagree. The value of unit test coverage roughly seems linked to economy of scale with larger projects/teams -- single devs on small projects likely don't offer their customers value with 100% coverage in lieu of more features; on the other hand, massive OSS projects with neutral Unit Test and Style arbiters allow hundreds of devs to contribute. Many LabVIEW projects tend toward the smaller spectrum. I've yet to work on a project, no matter how small, that wouldn't have benefited from at least a couple strategically-placed tests. YMMV. What are reasons to store the Manifest as a separate file from the LVClass?
  23. Slick. +1. Slick. +1. +1 for starting a great topic to drum up some awesome tricks.
  24. With regards to to the straightjacket -- this finally triggered a synapse none of us have keyed onto yet: unit testing. It's a manner in which the parent class can supply a bread crumb trail as to what is expected of a child class. Yet the child class can choose to fail or ignore these tests. Can we think of ways to incorporate unit tests as more of a first class feature of class definitions? Perhaps even making ad hoc execution of the tests as simple as right-clicking a ProjectItem that's part of the class?
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.