Jump to content

PROBLEM IN READING OTHER LANGUAGES TEXT


Recommended Posts

HI FRIENDS,

I AM FACING ONE PROBLEM.I AM HAVING ONE EXCEL SHEET WHICH CONTAINS 11 SHEETS IN EACH SHEET EACH LANGUAGE STRINGS WILL BE AVAILABLE FOR EX : ENGLISH ,GERMAN,RUSSIAN,CHINESE.... etc.. NOW I AM TRYING TO READ THIS EXCEL SHEET AND TO LOAD THE CORRESPONDING DATAS IN A TABLE CONTROL.WHILE READING A RUSSIAN LANGUAGE I AM FACING A PROBLEM THE STRINGS WERE DISPLAYED AS"????".. EVEN I HAVE ENABLED USEUNICODE=TRUE IN LABVIEW.INI FILE TOO. BUT STILL I AM FACING THE SAME PROBLEM.. CAN ANY ONE PROVIDE A SOLUTION FOR THIS smile.gif........

REGARDS,

KARTHIK

Link to post
Share on other sites

Hi Karthik,

check your keyboard, it looks like the shift key is stuck.

On topic, go deep inside the Office Toolkit to find out which method is used to load the data from Excel into LabVIEW, perhaps there is a Uni-code aware method you can use.

Keep us posted,

Ton

Link to post
Share on other sites

Hii,

No my shift key haven't struck .... still i am facing the problem while updating to Table....

What code do you use to get the data out of Excel?

The NI office toolkit, or some other toolkit?

Try to define which method is used to pump the data from Excel inot LabVIEW.

Ton

Link to post
Share on other sites

Hii,

No my shift key haven't struck .... still i am facing the problem while updating to Table....

So I was playing around with Unicode in LabVIEW stuff, and for some controls and indicators you need to append the BOM to the front of the string. In LabVIEW that is typically 0xFFFE to the front of the string. It worked for the tree contro and table. Here is an example. Tell me if it works for you.

UnicodeTable.vi

Link to post
Share on other sites

So I was playing around with Unicode in LabVIEW stuff, and for some controls and indicators you need to append the BOM to the front of the string. In LabVIEW that is typically 0xFFFE to the front of the string. It worked for the tree contro and table. Here is an example. Tell me if it works for you.

Hi GoGators,

How did you make your string constant has "Force Unicode Text" item in right-click menu.

Thanks

Link to post
Share on other sites

So I was playing around with Unicode in LabVIEW stuff, and for some controls and indicators you need to append the BOM to the front of the string. In LabVIEW that is typically 0xFFFE to the front of the string. It worked for the tree contro and table. Here is an example. Tell me if it works for you.

Hey your Table Contol is working fine..... but i am facing a problem while reading from excel sheet and then loading to Table control...............

Link to post
Share on other sites

On topic, go deep inside the Office Toolkit to find out which method is used to load the data from Excel into LabVIEW, perhaps there is a Uni-code aware method you can use.

What code do you use to get the data out of Excel?

The NI office toolkit, or some other toolkit?

Try to define which method is used to pump the data from Excel inot LabVIEW.

Hey your Table Contol is working fine..... but i am facing a problem while reading from excel sheet and then loading to Table control...............

Karthik,

could you please answer above question(s)?

Then we can help you.

Ton

Link to post
Share on other sites

Karthik,

could you please answer above question(s)?

Then we can help you.

Ton

ok i will list the things which i have done so for ,.....

1.I have LV 2009

2.I have enabled UseUnicode=TRUE in my LabVIEW.ini file.

3.In my control panal ->Regional Language->Language tab->I have enabled supplymentry language support.

4.I am having a excel sheet which contains russian language text.

5.I am using ActiveX for Excel read from LV and updating the datas in a Table Control..

6.While reading the russian language text it displays ?????......

this the current problem i am facing can u suggest me the right path to read those datas and display it in a Table control...........

:)

Link to post
Share on other sites

5.I am using ActiveX for Excel read from LV and updating the datas in a Table Control..

Look we are getting closer, could you post a codeshot/snippet of the exact ActiveX call that loads the data into LabVIEW?

Ton

Link to post
Share on other sites

Look we are getting closer, could you post a codeshot/snippet of the exact ActiveX call that loads the data into LabVIEW?

Ton

\

Hey Ton ,

Check my attached Pic like this only i am reading from XL sheet Using ActiveX.........

post-17451-1275569505_thumb.jpg

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.