Jump to content
Mars Su

No I/O port is detected

Recommended Posts

Hi fellows,

Need your helps!

I always use "VISA resource name" control to define the I/O port and it always work.(LabVIEW 2009)

Today suddenly I found that the "VISA resource name" control pulldown list shows nothing but "Refresh" ... ... :frusty:, nothing is detected. (I have a printer which is always connected so at least LPT1 should show up.)

Is it because certain relevant LabVIEW system application service is stopped?

What could the problem be?

Many thanks.

Best regards,

Mars

Share this post


Link to post
Share on other sites

I never see the printer ports (Have a USB one, not parallel). I have given up on the Prolific chips sets for serial com converters - maybe that is what you are using?. FTDI seems to be less troublesome. EasySync is their outlet

Share this post


Link to post
Share on other sites

Check the ports in MAX. Labview gets its VISA information from it and it will have better diagnostics.

Share this post


Link to post
Share on other sites

Shaun is right, you can check things in MAX. But you can't do anything in LV until you get your ports squared away. It's not really very useful until you get those working. LV is not very helpful for getting ports to work in the first place. Once you HAVE them working though, it's possibly superior to any other tool.

MAX has the unfortunate quality of just shutting down with an hour glass as long as something is wrong, and locking your interface.

If the port doesn't show up in LV, chances are something is really wrong, and Windows isn't recognizing it. If it's Mac or Linux, can't help.

Share this post


Link to post
Share on other sites

Thanks you ShaunR and InsaneObject!

Your suggestions do help.

When I check in MAX, I found the NI-DAQ is not installed :frusty: . (I haven't specifically informing our PC administrator to include this when he install LabVIEW for me. It's my own fault....)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.