Jump to content
Domint

When I run the program in LabVIEW there shows nothing in the "Read data" array

Recommended Posts

Good day,

I'm quite a beginner user of LabVIEW and wish to request some help from this forum regarding SPI communication.

I have a K-type thermocouple connected to a MAX6675 (cold junction compensated digital converter). It requires SPI communication and I connected the pins accordingly.

MAX6675 Arduino Uno
----------- --------------
VCC 5V pin
GND GND pin
SCK digital pin 13
SO digital pin 12
CS digital pin 10

1. I've loaded the LINX firmware into Arduino Uno.
2. Built the following block diagram.

Block_diagram.jpg

3. Set the SPI configuration as followed.

SPI_config.jpg

When I run the program in LabVIEW, nothing shows up in the "Read data" array.

Can anyone shed some light on what's wrong with my design??

Thank you.

Share this post


Link to post
Share on other sites

First is there any errors?  Second what is the value of Data?  This is important.  Leaving it blank will mean do nothing, where filling it in might mean to read specific memory registers.  You'll likely want to consult the manual, or even some other text based libraries to get an understanding of what registers need to be read, and how to scale the data that is read.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.