Jump to content

Installing vipm-17.0.2018-linux


Recommended Posts

I am trying to install the package manager, vipm-17.0.2018-linux, for LabView on Debian Linux and it is a total mess.

I copied the folder /JKI and all the contents to /usr/local. And installed the rpm files in the LabVIEW2015SP1RTE_Linux folder by converting them with alien to deb files. I removed the 32-Bit rpm files before converting them.

When i try to execute run it doesn´t find the libraries.

 

I will be grateful for any suggestions.

Link to post
Share on other sites
51 minutes ago, Yaw Mensah said:

I removed the 32-Bit rpm files before converting them.

Probably you shouldn't have. Forgot what I did then, but for me

$ file /usr/local/JKI/VIPM/vipm
/usr/local/JKI/VIPM/vipm: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux.so.2, for GNU/Linux 2.6.33, BuildID[sha1]=ff35d7adc7d9ef4e1ee0b41f6d67085e2c22dbe7, stripped

$ file /usr/local/JKI/VIPM/support/*.so
/usr/local/JKI/VIPM/support/lvanlys.so: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically linked, stripped
/usr/local/JKI/VIPM/support/lvzlib.so:  ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically linked, with debug_info, not stripped

 

Link to post
Share on other sites

In the folder there different files for different architecture.

For example I would delete nicurli-15.1.0-f0.i386.rpm but install nicurli-15.1.0-f0.x86_64.rpm

and nicurli-15.1.0-32-Bit-f0.x86_64.rpm. If i leave nicurli-15.1.0-f0.i386.rpm there alien report wrong architecture and doesn´t convert. 

image.png

Link to post
Share on other sites

file /usr/local/JKI/VIPM/vipm
/usr/local/JKI/VIPM/vipm: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux.so.2, for GNU/Linux 2.6.33, BuildID[sha1]=ff35d7adc7d9ef4e1ee0b41f6d67085e2c22dbe7, stripped
file /usr/local/JKI/VIPM/support/*.so
/usr/local/JKI/VIPM/support/lvanlys.so: ELF 32-bit LSB pie executable, Intel 80386, version 1 (SYSV), dynamically linked, stripped
/usr/local/JKI/VIPM/support/lvzlib.so:  ELF 32-bit LSB pie executable, Intel 80386, version 1 (SYSV), dynamically linked, with debug_info, not stripped
 

After that i tried executing vipm

sudo ./vipm

and i got command not found.

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.