Jump to content

Mass Compile and Subviersion


Recommended Posts

Hi all,

When I try to MassCompile directory under Subversion control LabView try to Mass Compile FOOBAR.vi.svn-base file in .svn subdirectory.

This spent a lot of time and it isn't exactly what I want to do...

It is posible to set some MassCompile Option to force ignore .svd directory ??

Thanks a lot,

Vladimir

Link to post

I dont think you can do that, but if you are using TortoiseSVN here is a work around (which may not be any faster).

1) Use the export function (right click over your folder>TortoisSVN>Export...) to export the whole directory structure to another folder (the svn folder are not exported)

2) Mass compile this new folder

3) Copy back (manually) the mass compiled files to the original folder under source control

4) Commit your changes

Note: If I were you I would be very carefull not to do anything to these files in the .svn folder. You might end up damaging your repository.

Good luck

PJM

Link to post
Hi all,

When I try to MassCompile directory under Subversion control LabView try to Mass Compile FOOBAR.vi.svn-base file in .svn subdirectory.

This spent a lot of time and it isn't exactly what I want to do...

It is posible to set some MassCompile Option to force ignore .svd directory ??

Thanks a lot,

Vladimir

You might try installing TortoiseSVN with the .Net Hack option, which can be selected during installation and causes the .svn folders to be named as _svn instead. This might (I have not tested it), cause the mass compile utility to ignore the _svn folders -- there are several instances where LabVIEW ignores folders and files whose names begin with an underscore.

Link to post
You might try installing TortoiseSVN with the .Net Hack option, which can be selected during installation and causes the .svn folders to be named as _svn instead. This might (I have not tested it), cause the mass compile utility to ignore the _svn folders -- there are several instances where LabVIEW ignores folders and files whose names begin with an underscore.

I have tried this manually, by renaming .svn to _svn, but with no effect.

Link to post

If this is a problem you face often, you might be able to write your own Mass Compile GUI.

I would:

1) rename the top-level directory (Project -> #Project#)

2) create a new Project folder

3) Recursively move folders and files from #Project# to Project, but leave out the .svn folders

4) Do a mass compile with an Application Invoke node pointing to Project

5) ?? Move the .svn folders to Project (will SVN rebuid those folders? I don't know. I used SVN at my old job, but haven't played with it in over a year)

6) Delete #Project#

I think this would work. SVN would see all your VIs as being changed, but that happens no matter what.

Pat

Link to post
  • 5 months later...

Here's how I handled it..

Open file Explorer and right click on the root diretory that you want to mass compile, then search for "*.svn.".

Zip up all of those .svn directories. Winzip has a function to "Save full path info". Be sure this is checked.

Now delete all of the .svn directories in the Search Results window.

Do the mass compile.

Last, unzip the all of the .svn directories back to their respective paths.

-James

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.