Jump to content
Sign in to follow this  
Bryan

LabVIEW 8.2 for Linux 'Auto-Close' Feature?

Recommended Posts

I've had LabVIEW 7.1 running successfully on Mandrake 10.1 for almost 2 years now. I just yesterday installed 8.2 (7.1 still installed) and have had problems getting it to do anything but load.

I don't think it's related to having 7.1 on board, but anytime I try to create a new VI or anything, LabVIEW closes. I'm able to create a new project, and items within a project, but as soon as I try to open/edit anything, it closes.

I launched LabVIEW 8.2 from a command prompt and when it closed I got the following error:

LabVIEW caught fatal signal

8.2 - Received SIGSEGV

Attempt to reference address: 0x0

Segmentation fault

Anyone have any ideas?

Share this post


Link to post
Share on other sites

Thanks for the link. It was actually a reminder. I had that issue with 7.1 and Fedora and had to do the tune2fs. I didn't have to do it when I installed 7.1 on Mandrake 10.1 for some reason. Mandrake had just become Mandriva at that time I believe (although I still hear it called Mandrake).

I tried it and had the same problem. The NI Knowledge Base says that problem was fixed in 7.1.1, so I would assume it would be in 8.2 as well.

Any other ideas?

Share this post


Link to post
Share on other sites
Any other ideas?

Unfortunately no. :unsure:

I've not had a chance to try LV 8.2 for Linux....or even for Windows yet. (Although the shiny new box for the Windows version is sitting beside me now)

Hopefully you'll be able to find some info somewhere.

Share this post


Link to post
Share on other sites

Bryan:

Try this. From a terminal, run this command:

strace labview > ~/strace.out 2>&1

Then do whatever it is that crashes LabVIEW and attach the strace.out file to this forum. I'll take a look at it.

Share this post


Link to post
Share on other sites

I did as requested and couldn't believe that it generated an 8MB file! I gzipped it down to 600-ish K.

Now it seems when I start LabVIEW 8.2 that if I just let it sit for a little while at the welcome screen, it will shut down on it's own. I looked at the file created a little and saw things that said "File not found". Can't figure out why it wouldn't see them.

Download File:post-404-1159530549.gz

Share this post


Link to post
Share on other sites
I did as requested and couldn't believe that it generated an 8MB file! I gzipped it down to 600-ish K.

Now it seems when I start LabVIEW 8.2 that if I just let it sit for a little while at the welcome screen, it will shut down on it's own. I looked at the file created a little and saw things that said "File not found". Can't figure out why it wouldn't see them.

Wow, I'm sorry. I thought I was subscribed to this post, but I guess not. I'll take a look at the strace output and see if I can determine the cause.

Share this post


Link to post
Share on other sites

I need more information. Add this to your .labviewrc file (in your home directory):

labview.DPrintfLogging: True

Then launch LabVIEW and get it to crash again. Then I want you to attach two log files from your /tmp directory. One will be named "LabVIEW_Failure_Log.username.txt" and the other will be "labview_8.2_username_cur.txt". Attach both of those.

Share this post


Link to post
Share on other sites

This looks like an OSMesa issue. Which video card do you have?

Here's a possible workaround (run these commands as root or use sudo):

#cd /usr/local/natinst/LabVIEW-8.2#cp linux/libOSMesa.so.4.0 patchlib/libOSMesa.so.4

To verify that this worked correctly, you can do this:

#ldd labview		linux-gate.so.1 =>  (0xffffe000)		libOSMesa.so.4 => /usr/local/natinst/LabVIEW-8.2/patchlib/libOSMesa.so.4 (0x40018000)		libGL.so.1 => /usr/lib/libGL.so.1 (0x40180000)		libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x401e7000)		libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x402e0000)		libdl.so.2 => /lib/libdl.so.2 (0x40308000)		libpthread.so.0 => /lib/tls/libpthread.so.0 (0x4030d000)		libstdc++.so.5 => /usr/lib/libstdc++.so.5 (0x4031f000)		libm.so.6 => /lib/tls/libm.so.6 (0x403dd000)		libgcc_s.so.1 => /usr/local/lib/libgcc_s.so.1 (0x40403000)		libc.so.6 => /lib/tls/libc.so.6 (0x4040b000)		libXxf86vm.so.1 => /usr/X11R6/lib/libXxf86vm.so.1 (0x4052a000)		/lib/ld-linux.so.2 (0x40000000)

Make sure that the libOSMesa line shows that path.

Then try running LabVIEW again. Let me know if this does or does not help. If it does, be sure to let me know which video card you have (and if you've installed any specific driver for it) so we can try to test it next time.

Share this post


Link to post
Share on other sites

I'm actually (at the moment) running Manrake as a Virtual Machine on my office desktop computer which uses a Matrox dual-head video card (Millenium P650)

I'll give those commands a shot and let you know. Thanks again!

--UPDATE--

Nope, still does it.

As I said before, I'm using a Matrox Millenium P650 video card, running Mandrake 10.1 on a Virtual Machine on my Windows XP Professional desktop computer.

Share this post


Link to post
Share on other sites

Virtual PC (Windows), the 2004 version that Microsoft is/was offering for free a little while ago. I've tried to install packages for it, but won't do it for Linux.

Share this post


Link to post
Share on other sites
Virtual PC (Windows), the 2004 version that Microsoft is/was offering for free a little while ago. I've tried to install packages for it, but won't do it for Linux.

Is there a way to get Virtual PC to connect the VM's CD-ROM drive to a .iso file? I really don't want to burn these CDs just for a virtual machine. I know this can be done in VMWare, but I don't see the option in Virtual PC...

:headbang:

EDIT: I figured it out. What a silly way to do that...

Share this post


Link to post
Share on other sites

Ok, this is definitely an issue with the DRI drivers/libOSMesa. I have a feeling that installing another version of Mesa would fix it, but in the process of trying to do so I was again reminded why I no longer use Mandrake. I couldn't find a binary update for Mesa, and the source version wouldn't compile because Mandrake doesn't come with all of the X headers. Then I was in RPM Hell trying to install them.

You have two choices which both have about an equal chance of resolving this problem:

1. Go through the trouble of installing the X headers somehow, and then downloading and compiling/installing Mesa (mesa3d.org) from source.

2. Upgrade to Mandrake 2006.

Both choices are annoying, but I'm not sure what else to suggest.

Share this post


Link to post
Share on other sites

Well, I've been using mandrake 10.1 because of it's ability to install to and run from a USB HDD without modification. I've been using this drive for testing of multiple OS-less units (it allows us to exercise I/O without having to install an OS and test apps), but I also do my development on it as well. I've installed 10.1 in a Virtual machine on my desktop so that I don't have to do development on the drive.

I'm not at a very good point now to try the Mandrake upgrade and pray that it will work on my bootable HDD. I don't want to risk breaking what already is working for us. I'm also somewhat of a Linux novice (I know just enough to be dangerous), so doing the Mesa upgrade probably isn't something I want to bother taclking at the moment.

Thanks anyway for all your help! At the very least, I know what I need to do if I get to the point I can upgrade to 8.2 in Linux. Most of the stuff I do is in Windows anyway, just this one part of a current project involves Linux.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.