Jump to content
Sign in to follow this  
nipon

MP3player_Sample

Recommended Posts

Hello everyone, attached is a MP3player_Sample that plays format MP3 and WMA files. Just for your fun. :laugh: :laugh: :laugh:

Share this post


Link to post
Share on other sites

Sawadee krop, and welcome nipon!

Very nice, cleanly written and responsive :thumbup:

Now I must look for my Carabao MP3s to test this further. Maybe you should have included at least part of "Made In Thailand" with the ZIP file :P

(Note: For others who download this, I loaded player with LabVIEW 8.2 and would crash when running the top level vi. I noticed that nipon's primary LabVIEW version is 7.1 and used that; it worked fine.)

Share this post


Link to post
Share on other sites

I must say I'm quite impressed (it happens alot)

I was trying to find a way to trim MP3 files (cut off 6seconds from the beginning) and was hoping your code could help me, but I see it basically uses alot of Call Library Function Nodes.

Also I had it crash several times even with LabVIEW 7.1. If I opened LabVIEW and told it to open the VI it would crash. But if I double clicked the file (when LabVIEW wasn't running) it would open LabVIEW and the VI properly.

Share this post


Link to post
Share on other sites

Hi Nipon,

Thanks for the nice mp3 player, good example of clean LV coding style.

BTW, pohm cow jai pasa thai nit noy kup.

P.S. Carabao is a great group, I saw them 2 years ago at a outdoor restaurant courtyard in Chang Mai.

Share this post


Link to post
Share on other sites

QUOTE(nipon @ May 3 2007, 05:48 AM)

Hello everyone, attached is a MP3player_Sample that plays format MP3 and WMA files. Just for your fun. :laugh: :laugh: :laugh:

Hi,

Nice interface, but I can't open MP3player_Sample.vi ,even I re-download the Zip enclosed file twice, My LabVIEW is 8.2.1, and the other Subvi works fine, what happenned ? anybody met this condition ?

Share this post


Link to post
Share on other sites

QUOTE(Cool-LV @ May 7 2007, 11:26 AM)

Hi,

Nice interface, but I can't open MP3player_Sample.vi ,even I re-download the Zip enclosed file twice, My LabVIEW is 8.2.1, and the other Subvi works fine, what happenned ? anybody met this condition ?

Hi,

attached is a MP3player_Sample for LabVIEW is 8.2.1 :laugh: :laugh: :laugh:

nipon

Share this post


Link to post
Share on other sites

QUOTE(nipon @ May 9 2007, 04:25 PM)

Hi,

attached is a MP3player_Sample for LabVIEW is 8.2.1 :laugh: :laugh: :laugh:

nipon

Hi,

MP3player_Sample Complete (for all Function). ;)

nipon

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.