Jump to content

DAQmx task not functioning


Recommended Posts

Problem Description :

Hardware: PXI-8184 (chassis PXI-1042), PXI-6221 (slot 2 in chassis)

Software: LV RT 8.5.1, DAQmx 8.7.1 (see MAX.jpg), Windows XP

Problem: Task does not function within program (CounterRead.jpg). I can run the task within MAX (MAX.jpg) while the program is running and I can see the counts. All other tasks work fine. I have eliminated everything else in my program except this task and it still doesn't function and I do not get any errors.

I hate to upgrade any of the drivers, if they're available, because I have several other units out in the field with the same configuration. I recently inherited this project.

I've tried different types for the task (raw, Counter Dbl 1Samp, etc).


Link to comment

The problem has been resolved. It was an initialization error. The default case would wipe out the task. Two other people (newbees) worked on this before me so I have a lot of clean up to do! Too many unnecessary variables, cases, etc.

Thanks for the reply.

Link to comment

There are still problems!!! Everything works fine as long as I run the code from the host computer. As soon as I dump it into the RT module, none of the digital works. From what I understand, this happened before on one of the previous machines (I'm working on # 4 of 4). Our local NI rep was in, did nothing, the previous programmer played around with it, and things started working. Well, they don't now. The only difference, and this may have something to do with it, it's a different processor (PXI-8184), same model but physically a different one. We had a hard drive fail in the field (temperature) and had to replace it. After jumping through hoops to get that to work, I fired everything else up (no changes to the software) and started encountering this problem.

I have a request in at NI for assistance. We'll see how that goes...

To summarize my problem: Everything works fine while running from the host computer (all my DAQmx tasks function properly)...as soon as I dump it to the RT module to run as start-up...no digital. I've even swapped slots to make sure that wasn't an issue.

I'm going to try and write something very, very simple to prove it all out but I've basically done that by disabling everything unrelated to the DAQmx stuff.


Link to comment

Found it...looking through the NI site I found a blurb regarding software updates being installed after drivers. Exactly what happened. Apparently the DAQmx drivers were updated 6/18 and Labview 8.5.1 upgrade was installed on 6/20. Since the drivers were the exact same ones, they were not updated. Uninstalled all, reinstalled and problem disappeared.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.