Jump to content

Network Shared Variables Deployment After Reboot


KWaris

Recommended Posts

Thanks all for valuable posts on this thread.

Here is my problem. I am the begineer only on NSV. And I really want to get this right.

I just designed a simple vi to stream the data from FPGA to RT and then to windows. By the way I am using CompactRIO with 9014 controller and 9114 chassis. Everything works find as long as its on development computer.

I managed to also make the communciation works when running the windows video as an executable and RT executable set to " Run at Start up".

However, as soon as I turned the CompactRIO off and turned it back again, the network shared variables seemed to have got undeployed. Even dont appear to be updating on the distributed manager. I can guarantee that RT vi is deployed and it is starting on start up. However, the shared variables does not seem to be updated on power loss and when the power is put back on.

Will appreciate if you guys can tell me what I shall be doing to overcome this problem.

Kind Regards

Austin

Link to post

What exactly do you see in distributed systems manager? If you see the variables then they are still deployed (and should be, even after a reboot).

The next thing to look for is errors. Selecting a variable in DSM should show a status bottom right of the screen. Also do you have a way of checking if the nodes in your code are generating errors?

Link to post

Strangely, I havent got them in distributed system managers anymore.

I can see the IP address of my cRIO, then the Library containing the variables but nothing inside the library.

I am only using 9012 controller with the total of 64 MB memory. The available is 12 MB after the installation of all the software add ons required for network variable communication and some others I required for example Network streams.

Link to post

I'm not sure what is going wrong, but I suggest you consider deploying the NSVs on Windows.... I don't think there is any advantage to deploying them on the cRIO anyway.

Link to post

I'm not sure what is going wrong, but I suggest you consider deploying the NSVs on Windows.... I don't think there is any advantage to deploying them on the cRIO anyway.

Would the advantage not be realized when having multiple Windows machines accessing a single cRIO? I do agree though, NSVs seem to give far fewer problems when hosted on the Windows side.

Link to post

Would the advantage not be realized when having multiple Windows machines accessing a single cRIO?

NSV's are publish-subscribe, so multiple Windows machines can still access the same SVs and therefore communicate with the cRIO. (We actually do this all the time.) (Of course, the host PC has to be running. This could be an important consideration depedning on the use case. For us that is easy to ensure.)

  • Like 1
Link to post

Right, I was envisioning an application such as a deployed system monitor that is periodically accessed by multiple Windows machines for example.

Ah! I see, OK! Good point!

Link to post
  • 2 weeks later...

My customer wants the following.

Turn the power to the pc on, the labview application loads up and FPGA starts streaming the data to the windows pc straight away. And they dont want the labview project, they want the .exe file. I developed the applicaton, however bypassed the RT controller for any digital I/O and used RT only for analogues. To stream RT from FPGA to RT, I used DMA FIFO and used Network stream to stream to windows. I did simple build, deploy and run as start up. 3 years done, it still works a treat. Bingo!

Now I need to design a control application for the same customer and create a signal and continously update the profile of this signal into FPGA. I designed the signal generator in windows, implemented it and found that the update rate was too low. In stead of having nice smooth curve, I must design the profile in the RT and implement PID in RT. I do however require to send some PID values, Output gain and some other binary signals from windows to RT. I am confident deploying the RT application containing the PID loop. However, when I add the shared variables to stream all the PID data from windows to RT and for other signals which require streaming from RT to windows, my application works only in the development environmet as long as the RT application is running and windows is running.

This is still unacceptable to the end customer as he wants to just press the button in the morning and let it run for the entire day. When I do the same steps the system fails and NSV doesn't seem to be deployed(proved).

I am sure people may have come acroos this before and will appreciate a great deal if some support is provided on this.

Kind Regards

Austin

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.