Jump to content
MikaelH

LV 2018SP1 f4 patch

Recommended Posts

Where did patch LV2018SP1 f4 go?
http://www.ni.com/product-documentation/55001/en/

I could download the f4 patch using these URLs (just by taking the f3 patch and rename the url):
http://download.ni.com/support/softlib/labview/labview_development_system/2018 SP1/Patches/f4/LV2018SP1_f4Patch-64.exe
http://download.ni.com/support/softlib/labview/labview_development_system/2018 SP1/Patches/f4/LV2018SP1_f4Patch.exe

But there is no official download link on NIs webpage, and I can't find it in NI Package Manager, but I'm sure it was available there a few days ago.
Does anyone know?!?
It feels like they removed it for some reason so I guess I shouldn't install it.

😟

 

Share this post


Link to post
Share on other sites

They are revamping the download portal for their software. The idea seems to be that in the future you should be able to go through this page for all downloads and for previous versions it should only allow you to download versions for which you have a valid SSP.

https://www.ni.com/nl-nl/support/downloads/software-products.html

However that page is borked in many ways (as a lot on the NI webserver) and depending on from where you come it won't allow you to download anything (even simple runtime installations) even if you are logged in with an account that has an associated SSP license, or it will allow you to download absolutely everything even without valid user account login. 😭 Why am I not surprised!!

Share this post


Link to post
Share on other sites
7 hours ago, MikaelH said:

Where did patch LV2018SP1 f4 go?
http://www.ni.com/product-documentation/55001/en/

The link at the bottom will bring you to this page http://www.ni.com/en-us/support/downloads/software-products/download.labview.html#305508

You just have to select 2018 SP1 Patch and click download. This will download the f4 (latest) patch.

147534969_LV2018SP1f4Download.jpg.d48e5f99fb332e6e1bc3321110a66989.jpg

17 minutes ago, Rolf Kalbermatter said:

However that page is borked in many ways (as a lot on the NI webserver)

The en-us version is pretty stable in my experience (except for a few dead links here and there). Can't say much about the others.

19 minutes ago, Rolf Kalbermatter said:

and depending on from where you come it won't allow you to download anything (even simple runtime installations) even if you are logged in with an account that has an associated SSP license, or it will allow you to download absolutely everything even without valid user account login😭 Why am I not surprised!!

I'm still surprised they bother to check the associated SSP. Considering that the License Manager checks it anyway.

  • Like 1

Share this post


Link to post
Share on other sites
19 minutes ago, LogMAN said:

The link at the bottom will bring you to this page http://www.ni.com/en-us/support/downloads/software-products/download.labview.html#305508

The en-us version is pretty stable in my experience (except for a few dead links here and there). Can't say much about the others.

I get redirected to the nl-nl page anyhow no matter what I do. And on that I can't download any versions prior to the 2019 version no matter if I only select the runtime version or if I'm logged in or not. On the page that I get to when clicking on the LabVIEW icon on the earlier mentioned download portal I get to https://www.ni.com/nl-nl/support/downloads/software-products/download.labview.html# (without the number at the end) and while it seems I can download anything (the Download button is always enabled), nothing happens except a page refresh when pressing that button.

On another link with a different number at the end that I found mentioned in a forum post I could download absolutely anything, including the Linux-Mac downloads!

Edited by Rolf Kalbermatter

Share this post


Link to post
Share on other sites
13 minutes ago, Rolf Kalbermatter said:

I get redirected to the nl-nl page anyhow no matter what I do.

You need to change the location manually at the bottom of the page. After that you should always get to the same site.

2019-06-11_14-53-42.jpg.d12ef5cacb8165d0a5286d51bd792848.jpg

13 minutes ago, Rolf Kalbermatter said:

And on that I can't download any versions prior to the 2019 version no matter if I only select the runtime version or if I'm logged in or not.

That is strange indeed. I just tried on another browser and can't seem to recreate this behavior, no matter which location I choose.

13 minutes ago, Rolf Kalbermatter said:

On the page that I get to when clicking on the LabVIEW icon on the earlier mentioned download portal I get to https://www.ni.com/nl-nl/support/downloads/software-products/download.labview.html# (without the number at the end) and while it seems I can download anything (the Download button is always enabled), nothing happens except a page refresh when pressing that button.

Do you have extensions installed which block JavaScript or tracker?

They can sometimes cause strange results like this, especially if contents are dynamic (as the download button or the lock for Linux/Mac versions).

Edited by LogMAN

Share this post


Link to post
Share on other sites
4 minutes ago, LogMAN said:

Do you have extensions installed which block JavaScript or tracker?

They can sometimes cause strange results like this, especially if contents are dynamic (as the download button or the lock for Linux/Mac versions).

Minimal extensions installed which should not affect this:

Adobe Acrobat, Cisco Webex Extension, Google Analytics Opt-Out , Google Docs Offline, XML Viewer

Chrome addons:

Docs, Sheets, Slides

Nothing else.

Share this post


Link to post
Share on other sites

Very strange indeed. You are right, these extensions should not affect any of this.

I just installed the "Disable JavaScript" addon and can reproduce your behavior with the download button and version selection. In my earlier post you see the "normal" page. This is how it looks with JavaScript disabled:

Also, the download button now statically points to http://www.ni.com/en-us/support/downloads/software-products/download.labview.html#

1712727037_DownloadNoJS.jpg.ce73da0c0a5d39531bbe90b1dab2201f.jpg

Share this post


Link to post
Share on other sites

Thanks guys, yes the option: "2018 SP1 Patch" is indeed the f4 patch

Share this post


Link to post
Share on other sites
19 hours ago, LogMAN said:

Very strange indeed. You are right, these extensions should not affect any of this.

I just installed the "Disable JavaScript" addon and can reproduce your behavior with the download button and version selection. In my earlier post you see the "normal" page. This is how it looks with JavaScript disabled:

Also, the download button now statically points to http://www.ni.com/en-us/support/downloads/software-products/download.labview.html#

1712727037_DownloadNoJS.jpg.ce73da0c0a5d39531bbe90b1dab2201f.jpg

Well looks like my case but I'm not aware that I have Java Script disabled anywhere. And with another page (different number at the end) I could suddenly download everything independent on if I was logged in or not.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.