Jump to content

LogMAN

Members
  • Content Count

    365
  • Joined

  • Last visited

  • Days Won

    28

Posts posted by LogMAN


  1. @hooovahh is right, this is not doable. Your executable doesn't contain the source code and without the source code you cannot compile the application. If the source code is lost, you can either re-program the application (probably very costly) or convince your IT department to allow installing the LV2009 RTE for this particular executable.

    That said, it is possible to copy the executable and the entire RTE to the target computer manually, for example as part of the "installer" for your executable (IT department mustn't know 😉). We have done so in the past (for the same reasons) and it works like a charm. Of course, this only works for utility applications. It doesn't work if your application depends on other drivers like VISA and the like. If this is not a problem for you, just copy the RTE folder from the NI installation directory ".\Shared\LabVIEW Run-Time\2009", put your executable inside and be happy. I just ran your application on a clean Windows 10 virtual machine and it starts without errors and terminates after a few seconds. It's worth a try in my opinion.

    • Thanks 1

  2. I had the same issue just now. Looks to me like something is wrong with the database (maybe an incomplete update?).
    This is the closest information I could come up with: https://www.mediawiki.org/wiki/Topic:U26n1a1pgo0078tt

    Interestingly enough, after this error, there are two entries of the same file with the same timestamp.
    The preview correctly shows the file I tried to upload. Still, it shows the old image in articles.
    I don't think there is much we can do about it, one of the Admins will have to look into this.

    image.png.ddcee1f75957b1989823d54ad64b0cc2.png

    https://labviewwiki.org/wiki/File:Functions_Palette.png


  3. I found some spam on the wiki and would like to request deletion, but there doesn't seem to be an option (probably because I don't have the rights).
    So, is there a way to notify administrators (currently only @Michael Aivaliotis?) directly or should we open new topics here?

    Here are the offending pages.

    Edit: There also seem to be some orphan files that should be released of their existence:

    There is no end to this...

    Saving because I don't want to loose progress...

    Done.

    • Thanks 2

  4. 9 hours ago, Aristos Queue said:

    You people are so laid back and forgiving. I’m an editor on multiple wikis across cyberspace, and none of the others are anything less than draconian.

    LabVIEW doesn't backfire for misspelled words, which means we don't freak out every time we see one.

    But-Thats-None-Of-My-Business.jpg.d3d310ee00b6a5b67d0b5074544c6355.jpg

    Here are a few suggestions for draconian rules on the LabVIEW wiki 😇

    1.1 Uploading sample code to the wiki

    • Put input terminals to the right, output terminals to the left (on the block diagram and VI terminals)
    • Use backwards wiring
    • Show terminals as icons
    • Don't use shift registers (use local variables instead)
    • No error handling (disable debugging)
    • Take a screenshot with your mobile phone (compress as much as possible before uploading)

    Seriously, though. The wiki should have some guidelines for the structure and content of each article. Otherwise it will decay to some kind of link collection (formally known as favorites) with no added value (example). Those guidelines should be more general, as in:

    • A page must be informative
    • It should focus on one topic (create new pages for other topics)
    • Citations must be marked clearly using the format "<blockquote>Someone said this!</blockquote>"
    • ...

    My point is: This page should be updated (last edited on 7 October 2007, at 11:18): https://labviewwiki.org/wiki/LabVIEW_Wiki:Manual_of_Style

    • Like 1

  5. 2 hours ago, poc said:

    Where did you find it?

    I don't think they found the documentation, just an answer to their particular question or a solution to their particular problem. As Rolf mentioned above:

    On ‎10‎/‎3‎/‎2007 at 9:18 AM, Rolf Kalbermatter said:

    … someone ELSE could put some time into it to help with documentation if they feel it is needed.

    Documentation probably still doesn't exist.


  6. Very strange indeed. You are right, these extensions should not affect any of this.

    I just installed the "Disable JavaScript" addon and can reproduce your behavior with the download button and version selection. In my earlier post you see the "normal" page. This is how it looks with JavaScript disabled:

    Also, the download button now statically points to http://www.ni.com/en-us/support/downloads/software-products/download.labview.html#

    1712727037_DownloadNoJS.jpg.ce73da0c0a5d39531bbe90b1dab2201f.jpg


  7. 13 minutes ago, Rolf Kalbermatter said:

    I get redirected to the nl-nl page anyhow no matter what I do.

    You need to change the location manually at the bottom of the page. After that you should always get to the same site.

    2019-06-11_14-53-42.jpg.d12ef5cacb8165d0a5286d51bd792848.jpg

    13 minutes ago, Rolf Kalbermatter said:

    And on that I can't download any versions prior to the 2019 version no matter if I only select the runtime version or if I'm logged in or not.

    That is strange indeed. I just tried on another browser and can't seem to recreate this behavior, no matter which location I choose.

    13 minutes ago, Rolf Kalbermatter said:

    On the page that I get to when clicking on the LabVIEW icon on the earlier mentioned download portal I get to https://www.ni.com/nl-nl/support/downloads/software-products/download.labview.html# (without the number at the end) and while it seems I can download anything (the Download button is always enabled), nothing happens except a page refresh when pressing that button.

    Do you have extensions installed which block JavaScript or tracker?

    They can sometimes cause strange results like this, especially if contents are dynamic (as the download button or the lock for Linux/Mac versions).


  8. 7 hours ago, MikaelH said:

    Where did patch LV2018SP1 f4 go?
    http://www.ni.com/product-documentation/55001/en/

    The link at the bottom will bring you to this page http://www.ni.com/en-us/support/downloads/software-products/download.labview.html#305508

    You just have to select 2018 SP1 Patch and click download. This will download the f4 (latest) patch.

    147534969_LV2018SP1f4Download.jpg.d48e5f99fb332e6e1bc3321110a66989.jpg

    17 minutes ago, Rolf Kalbermatter said:

    However that page is borked in many ways (as a lot on the NI webserver)

    The en-us version is pretty stable in my experience (except for a few dead links here and there). Can't say much about the others.

    19 minutes ago, Rolf Kalbermatter said:

    and depending on from where you come it won't allow you to download anything (even simple runtime installations) even if you are logged in with an account that has an associated SSP license, or it will allow you to download absolutely everything even without valid user account login😭 Why am I not surprised!!

    I'm still surprised they bother to check the associated SSP. Considering that the License Manager checks it anyway.

    • Like 1

  9. Here are some additional pointers that might be helpful

    I also found a blog post with pictures that show the general process for customizing controls.
    https://www.dmcinfo.com/latest-thinking/blog/id/9428/basic-labview-ui-control-customization

    If you are interested to see what is possible with LV, search for "2016 NIWeek - Designing Advanced User Interfaces in LabVIEW".
    https://lavag.org/topic/20645-labview-videos-tecnova-download-site/

     

    • Thanks 1

  10. Disclaimer
    The following details are oversimplified for the sake of clarity. Feel free to point out important details that aren't covered by this post.

    ---

    There is a higher chance of finding better results by searching for "labview reference". Here are a few examples.

    That said, you should be familiar with the normal data flow in LabVIEW.

    • Data goes from one end of a wire to the other.
    • A branch in the wire will create a copy in memory if either branch of the wire is changed.

    Loosely speaking, a wire represents the data.

    A refnum on the other hand doesn't represent the data, but the location of the data in memory (*). It is similar to a pointer in C-like languages.
    This changes the behavior of the wire

    • Data still goes from one end of a wire to the other.
    • Each branch of a wire receives exactly the same value as the other (no copy is made). (**)
    • In order to access the data you need to make use of Property Nodes, Invoke Nodes and more.

    The benefit is, that you can access the same value from different places in your program. Even better, this is not limited to controls.
    It works for controls and indicators, VIs, objects, the project, the whole application and everything.

    However, it doesn't work for variables and due to its nature, race conditions can occur if you don't take care of the execution in your program.
    This is why for variables there is a more specialized type of reference, the data value reference (DVR). It allows you to access the same variable in memory from different places in your program.

    There is obviously much more to it than these few points. However, the links above should give you some insight.

    (*) Here is some information about the memory structure of a refnum. https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z0000019ZT5SAM&l=en-US

    (**) Technically speaking a copy is still made if you change the "value" on either branch of the wire, but since it is a pointer you shouldn't change it under any circumstances.

    • Like 1
    • Thanks 1

  11. 4 hours ago, 0_o said:

    How do you organize important posts you read and want to save for the time of need?

    Brain power and Google is the standard solution if the search box at the top doesn't satisfy you.

    That said, I'm using firefox, so Pocket is one way to keep track of it. https://www.mozilla.org/en-US/firefox/pocket/

    And of course you can make use of bookmarks in your favorite browser, but chances are high that it grows so much that you need Google again.

    4 hours ago, 0_o said:

    For example, I want to save an interesting post from Lavag/NI Forums or any other LV blog. 

    This post might contain VIs and I would like to tag it in a way that will let me find it when it becomes relevant.

    I would like such a post to be saved locally like an RSS so that I'll get the new comments and won't depend on the site to keep the links alive.

    Most of it can be done with Pocket. You get a button which you press while on the page. It stores the page in your Pocket (online) and you can add tags to it. You can also subscribe to an RSS feed of your personal pocket. But it doesn't update contents in your Pocket automatically and the RSS feed only contains the things you add to the Pocket.

    For live updates I suggest using the notification feature of Lava (mail based).

    4 hours ago, 0_o said:

    I see the veterans here keep track of all the new posts and even offer solutions by giving links to some old posts without having to search for them sometimes.

    Rest assured, searching was involved. hooovahh summarized it perfectly.

    4 hours ago, 0_o said:

    I hope to hear of some cool little RSS app that will let me search through the tagged vis and posts stored on my computer and not about some bookmark manager.

    To collect the information on your local computer you can use any feed reader you like. But I highly doubt there is any that automatically downloads attachments for you (because that is web scraping, not news reading).


  12. 32 minutes ago, rscott9399 said:

    I have a VI that is very complex that i did not write. Needless to say life is difficult right now

    ...

    AKA a complete bit 

    Thank you very much, this just made my day 🤣

    11 minutes ago, rscott9399 said:

    I have gone to the example folders and found the folder but its not in there

    You'll find the function on your palette under Timing.

    Alternatively press Ctrl+Space and write "Stall Data Flow", it should appear in the list.


  13. If I understand you correctly, there is a path like "C:\a\b\c" and you need the "\b\c" in order to use it as "D:\default\b\c", right?

    Use this to check if one path is relative to another http://zone.ni.com/reference/en-XX/help/371361R-01/glang/compare_two_paths/

    It returns the relative part which you can combine with your default path. I don't have access to LV right now, but this should be straightforward.


  14. 5 hours ago, LAVA Good said:

    How can I improve my while loop speed?

    There are multiple ways actually. Here are a few that come to mind:

    1. Let it run faster by adjusting the code inside the loop accordingly
    2. Split it into multiple loops to utilize more cores of your CPU
    3. Buy a faster computer

    Note that there is a limit to how many concurrent threads LV supports: https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z000000PARmSAO&l=en-US

    5 hours ago, LAVA Good said:

    And What is the maximum speed in while loop?

    The maximum speed of a while loop is only limited by the speed of your CPU at 100% load (and of course the way your operating system shares the CPU between processes and threads). That is assuming your loop does nothing, which makes it pretty useless. Of course, if your computer has multiple cores, you can run multiple loops in parallel to make use of them.

    4 hours ago, LAVA Good said:

    Oh my code is simple. I just want to know how to reduce loop speed :) anyway thank you for your reply

    This is contradictory to your first statement. I suppose you mean to increase the loop speed, right?

    If your code is simple, it should be easy to optimize for speed or to run multiple instances concurrently if applicable.

    • Thanks 1

  15. Here are some links to MS Docs that might be helpful:

    The second one is for Vista. I couldn't come up with any information on W10, so details can/will differ.

    Not sure if I misinterpret the information, but shouldn't the ARP table keep updating (i.e. not sending additional ARP requests) while packages are being transfered, or is this limited to TCP?

    If an entry is not used for a time between 15 to 45 seconds, it changes to the "Stale" state.
    Then, the host must send an ARP Request for IPV4 to the network when any IP datagram is sent
    to that destination.

    RFC 826 only mentions timeouts briefly:

    It may be desirable to have table aging and/or timeouts. The
    implementation of these is outside the scope of this protocol.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.