Jump to content

Linux "flavors" used to support LV

Val Brown

Recommended Posts

In particular I will want to also support running Linus under VMWare Fusion, so would esp like input for others who had done that specifically.

I have not specifically used LV in a *nix virtual machine, but as a warning VMs tend to make direct hardware access difficult or impossible, in case you were planning to run DAQ/Vision/etc.

Link to comment

Hi Val,

Official LabVIEW for Linux support is currently limited to 3 distros (although unofficially I am aware people have managed to run on many more). The key distros targeted are Red Hat and SUSE but support for Scientific Linux has increased in the past few versions. The full support table for Linux is at http://digital.ni.com/public.nsf/allkb/4857A755082E9E228625778900709661?OpenDocument.

From my experience I have tended to come across more people using Red Hat but I think this is an enterprise thing rather than any technical reasoning.


James Mac

Link to comment

Haven't tried linux distros (don't know what DAQ drivers are supported anyway) but I have had success running DAQmx in Window VM's with the later VMware releases (as opposed to a few years ago).

Yes, the latest VMWare Fusion (4.1 I believe) actually does a pretty fair job with direct hardware calls for W7. I have a driver for a USB device with a double enumeration that I wrote with the LV wizard and it works pretty well -- at least for initial development work. Since we deploy on native W7 systems I do final testing on those but for development work, Fusion does the job and lets me have a single laptop to carry around.

Link to comment

Does it require you to install a tool, a bit like the integration toolkit used by Microsoft VPC? IIRC, VMWare has something akin.

Actually it's a "standard" install which includes installing the Guest appropriate VMTools so nothing unusual to support hardware (e.g. USB) under Windows as a guest in VMWare Fusion. I know others who use Parallels which I used to use until I became REALLY annoyed with their "licensing" process. :throwpc:

So I switched to Fusion and have been a happy camper ever since. :thumbup1:

So.....back to the OP's question: What flavor of Linux have you been using to support LV?

In particular has anyone used unbent?

Link to comment
  • 2 years later...

I've always avoided Ubuntu as the LabVIEW installers uses rpm based installers but ubuntu uses debian packages.


It is theoretically possible, from memory I think there is a program called Alien or similar that allows rpms to be installed to ubuntu and I know someone tried LabVIEW with this somewhat successfully. Alternatively any of the supported should work (Red Hat, OpenSUSE, Scientific Linux) or RPM based shouldn't have major issues. Believe I have had success in the past on Fedora, CentOS and Manjaro (Fedora and CentOS are closely related to RedHat, Manjaro was luck! but had some font issues)

Link to comment

I'm running LabVIEW on Ubuntu, and it's working pretty good. Mostly I'm still at 8.6 but I've installed up to 2012 and it is all running well. In 8.6 I have some quirks, more silent crashes than I would expect in Win, some computers have severe graphics problems with LV, fonts can be a bit messy although I suspect thats a general LV for Linux issue. Sometimes the windows management (KDE) can mess up a bit.


I've developed a product that runs on a dedicated slimmed down Ubuntu distro with LV-RTE and that works fine, although I've hit performance degradation on those computers (while others show improvement) in later LV version, which is why I'm still at 8.6.

Link to comment

Ubuntu can be made to work but depending on your Linux hacker abilities might be either a nice challenge or a nightmare. :lol:


The biggest problem is the packaging since LabVIEW comes as RPM package while Ubuntu wants Debian. It can be worked around with various tools but at least in older LabVIEW versions you then easily run into libc compatibility issues with the database manager interface that comes in the LabVIEW distribution to handle non RPM systems. Not sure if that has changed in newer LabVIEW distributions. After that you have the potential to run into libc issues with LabVIEW itself and might have to add the correct symlink to the correct libc library to allow LabVIEW to run properly. Not to speak about other library problems with OpenGL Mesa for instance depending on your Ubuntu version.


Everything is usually solvable by either installing the right version of the affected library or sometimes just by symlinking the expected library to the actually installed one, and in one case that I saw by disabling some new kernel feature that messed up an older LabVIEW version, but without some deeper Linux hackability knowledge it is likely a painful exercise that might lead nowhere to a successful installation.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.