Jump to content
Bobillier

Default Conepane

Recommended Posts

Hi

Perhapse i'm stupid :frusty: , but i don't find how define default conepane for CTRL-N short cut. Previously i have one "4815" conepane each time, and now it's "4834" . I have try to modify "defaultConPane" parameter in labview.ini but without effect, and when close Labview "defaultConPane" parameter go back to "4834" :wacko: .

Any suggestion?

Regards

Eric

Share this post


Link to post
Share on other sites

Just to confirm, you're not trying to edit the LabVIEW.ini file while LabVIEW is running, right?

  • Like 1

Share this post


Link to post
Share on other sites

Crelf: Are you saying the LabVIEW.ini file reverts after you make changes and save it?

Eric: Yes it's true.

Ned: Just to confirm, you're not trying to edit the LabVIEW.ini file while LabVIEW is running, right?

Eric: No i stop Labview and modify labview ini and restart Labview.no effect if i creat new vi. Stop labview and look labview ini and then see conepane go back to old value.

Just another details: i have samethings on LV2009 SP1 and LV2011 under Windowx XP sp3..

Share this post


Link to post
Share on other sites

Crelf: Are you saying the LabVIEW.ini file reverts after you make changes and save it?

Eric: Yes it's true.

Ned: Just to confirm, you're not trying to edit the LabVIEW.ini file while LabVIEW is running, right?

Eric: No i stop Labview and modify labview ini and restart Labview.no effect if i creat new vi. Stop labview and look labview ini and then see conepane go back to old value.

Just another details: i have samethings on LV2009 SP1 and LV2011 under Windowx XP sp3..

I believe I had the same issue on LabVIEW 2011.

My solution was

  • remove the defaultConPane key from the ini file and start LabVIEW.
  • Stop LabVIEW
  • re-add the ini file token

/J

Share this post


Link to post
Share on other sites

Thanks but for me your trick is not good.

If i remove the defaultConPane key and start and stop Labview, the defaultConPane key go back with defaultConPane="4834" in labview.ini file. :frusty:

Edited by Bobillier

Share this post


Link to post
Share on other sites

Something must be writing it. Try putting a breakpoint in

<LabVIEW>\resource\dialog\lvconfig.llb\LV Config Write Numeric (I32).vi

(make a backup copy of this llb first in case you need to restore it)

Share this post


Link to post
Share on other sites

I have the same issue.

  • It's not changed by <LabVIEW>\resource\dialog\lvconfig.llb\LV Config Write Numeric (I32).vi or <LabVIEW>\resource\dialog\lvconfig.llb\LV Config Write String.vi
  • It's changed just before the 'Getting Started Window' is shown
  • It's changed when I open a project from the GSW
  • It started recently. I suspect the f2 patch for 2011 (however my startup window says I only have the f1 patch installed)
  • I have the following providers installed:
    • ADDQ
    • Symbio GOOP

    [*]It's stored as defaultConPane="4834"

    [*]I have WinXP with English OS with Dutch localization (a ',' as decimal sign)

    [*]LabVIEW 11.0.1f1

Ton

  • Like 1

Share this post


Link to post
Share on other sites

Ton

You are right, it's ADDQ (i don't have GOOP installed) who systematicaly modify the connector pane.

To solve this:

Go to Tools\G#IDE\Options and Define connector Pane.

ADDQ seem have common configuration between all Labview versions installed, because i have made modification on LV2011 and that automaticaly solve this in LV2009 without any action of me.

Thanks to all for your help.

Regards

Eric

  • Like 1

Share this post


Link to post
Share on other sites

Eric,

Is it because "6x4x4x6" being the first item in the list, and not "4x2x2x4"?! I was facing this issue in LV2016, and it was a nightmare for more than 2 weeks now, until I just stumbled upon this post, esp your reply!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.