Jump to content
mje

Preventing System-Style Controls From Resizing With OS Font Settings

Recommended Posts

I'm annoyed by a particular behavior of LabVIEW in that it seems to resize controls from the system palette if the operating system's font settings are changed, and how sometimes this resizing is handled rather poorly. For example:

 

post-11742-0-46875100-1383057884.png

 

The left half is the intended UI, and the right is what happens if the OS is set to a font size of 125%. Don't even get me started on 150%, the amount of whitespace a UI needs to leave at 100% to support a 50% increase in size is just rediculous.

 

There's really two things going on here that I don't like.

 

The system ring controls clip when font size is not 100%. This is visible in the controls that have the strings "Insulin_ChainA" or "Rel Fract Uptake" displayed. Note however the combo box renders correctly. Doubt I can do anything about this, but this behavior strikes me as unintended.

 

The other issue is the resizing of my image based controls. They're derived from system palette controls because I wanted the hover effect on them. All of them are set to not show the boolean text (even so boolean text properties are left empty), yet still they are resized by the font settings. Is there any way to prevent this?

 

As I see it with the image control resizing I can either go back and re-create them such that they're bigger and won't be resized at 125%, or maybe force them into submission by programmatically setting their size, or just ditch system controls (thus losing the automatic hover effects) and hope other controls don't have this resize behavior (confirmation anybody?). Vector based graphics would also help but...

Share this post


Link to post
Share on other sites

Sweet. I was aware of those ini keys but had no idea that they would keep LabVIEW from honoring the OS font scaling settings. Kudos to you, sir!

 

I do however wish I knew what the "0", "1", etc meant in place of the font name, I hadn't seen that syntax before.



I'll add that the settings don't appear to solve the issue with the ring controls clipping however, but that I can live with.

Share this post


Link to post
Share on other sites

Glad that helped.

 

I seem to recall somebody on the darkside (Christina?) telling me (or somebody else, memory no good these days) that the number is like an index into some global font list or something.

  • Like 1

Share this post


Link to post
Share on other sites
Glad that helped.

 

I seem to recall somebody on the darkside (Christina?) telling me (or somebody else, memory no good these days) that the number is like an index into some global font list or something.

 

So I'm on the dark side now? :lol:

 

http://lavag.org/topic/16925-controls-change-positions-on-runtime-system/?p=103828

 

neil, I am your father...

 

;) maybe...

Share this post


Link to post
Share on other sites
So I'm on the dark side now? :lol:

 

http://lavag.org/topic/16925-controls-change-positions-on-runtime-system/?p=103828

 

neil, I am your father...

 

;) maybe...

That thread is from June, I told you my memory was bad  :lol:

 

I do seem the recall a thead on the darkside discussing fonts and this was where I first learned this tip. Of course I cannot find the thread anymore. Thanks for the reminder though, Anakin.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.