Jump to content
Neil Pate

NI Package Manager Issues

Recommended Posts

I really am not a fan of the new NI Package Manager. Having so much drama with it across multiple computers.

Cannot install the Vision Development Module 2019, the installer just closes soon after starting, no error messages or anything.

Staring Package Manager directly gives this error:

image.png.60eac9bfc6f0ca6b2fd00c6807b8f4a0.png

 

Anybody else having issues?

Share this post


Link to post
Share on other sites

It has been a hot mess with trying to get 2019 installed on my laptop. It killed all DAQmx support for 2018, but had options for the other version installed. Then wouldn't uninstall correctly and the NI website has simultaneously revamped ni.com/downloads making a standalone nearly impossible to find. Can we have ni.com/src back?

  • Sad 1

Share this post


Link to post
Share on other sites

That error looks suspiciously like one I was getting when trying to uninstall software after something got messed up on my system (MSI files for uninstall were missing). There is (at least currently) a way around the package manager as listed in the knowledgebase article:

https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z000000P70TSAS&l=en-US

in the section "Software installed originally without NI Package Manager". This brings up the old interface which has the repair option. This was able to fix a bunch of installations which I couldn't uninstall before repairing.

There are error logs that NI tech support had me send them which read pretty good for debugging the installer issue:

https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z000000P6FcSAK&l=en-US 

Share this post


Link to post
Share on other sites

Thanks Tim, the problem is I cannot even install the stuff in the first place!

NI Package Manager is not my favourite piece of software at the moment...

Share this post


Link to post
Share on other sites

Getting absoerrorlog.txtlutely nowhere with this. Reinstalled my OS, managed to install LV2019, now cannot install any RT stuff. Package managed is choking on NI-Serial.

 

===== 2019-Aug-12 22:44:11.734283 =====
Exception in ni::pkgclient::TransactionBase::StartInternal. Error code: -125083
Request type: 30
-125083: An error occurred while installing a package: ni-serial-runtime (19.0.0.49152-0+f0)
File: source\nipkg_client\pkgclient\PluginInteraction.cpp
Line number: 237

Additional error information:
-125530: An error occurred while installing the MSI at 'serialRuntime64.msi'. 
File: p:\AST\PackageManagement\components\nipkg\trunk\19.0\source\shared_agents\WinInstall/ErrorHandler/ErrorInfo.h
Line number: 111

Anybody know what these error codes mean?

Share this post


Link to post
Share on other sites
1 hour ago, Neil Pate said:

Anybody know what these error codes mean? 

I found a post with the exact same error codes: https://forums.ni.com/t5/SystemLink/Package-deployment-failed-through-SystemLink/td-p/3839425 (Google had exactly 1 hit on ni.com)

JoshuaP suggests installing ni-certificates first. (His solution is for SystemLink rather than NIPM, so I'm not sure how applicable it is to your case)

Edited by JKSH

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.