Jump to content

Help with c-Series Module Selection


BrentonLang

Recommended Posts

I'm needing two c-series Modules for the CompactDAQ. They are a GPS module and an accelerometer module. I know that S.E.A. sell a GPS c series module, but it is only compatible with cRIO, not cDAQ, obviously with the different interfaces.

Does anyone know of any companies that sell GPS and accelerometer modules for the cDAQ?

Thanks.

Link to post

Don't think you'll have any luck with GPS. I am not certain but modules outside of data acquisition on cDAQ is very rare.

There are modules designed For reading from accelerometers but again not with anything built in. What you could do is get the module development kit and put a standard gps unit powered from the backplane but then run a serial cable out the front.

(null)

Link to post
I know that S.E.A. sell a GPS c series module, but it is only compatible with cRIO, not cDAQ, obviously with the different interfaces.

Like you said, cRIO yes, cDAQ no. I've never used them, but I hear the S.E.A. modules are quite good - and they've been around for a long time (well, in cRIO terms).

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By Gan Uesli Starling
      I have a LabVIEW program, which when operating with simulated input data is blazing fast during mock-up. As soon as I hooked into a real cDAQ on Windows, however, the update speed fell off to 4 seconds. That's awful slow. I don't really have a whole lot of channels. I have read tasks for Volts of maybe 5 channels, write tasks for both On./Off for maybe 10 channels (simultaneous) and write tasks for 4-20mA of only 5 channels. How may I improve on that? Is it maybe a priority issue in Windows or to do with USB? What? How to improve? Thanks in advance.
    • By Manudelavega
      Hi, I have contacted NI sales services but it's a great frustration as usual, so I will try to get some support here
       
      Basically for a project I need 2 CAN ports and I decided to go with XNET and Compact DAQ. I have 2 solutions I try to choose from:
       
      Solution 1 --> One 4-slot chassis with 2 NI-9862 modules (one port per module)
      Solution 2 --> One 1-slot chassis with 1 NI-9860 module (this module has 2 ports)
       
      I am confident that solution 1 will work well since I already had a project in the past with one 4-slot chassis (cDAQ-9174) and one NI-9862 module. But going with solution 2 will allow me to cut cost significantly. I just want to make sure it will be absolutely seamless and transparent for the software. Does anybody have experience with the NI-9860? Can it be considered as the equivalent of 2x NI-9862 as far as the software is concerned (LabVIEW driver) or does it remove some performance/flexibility/other?
       
      Thanks!
    • By bvrm
      Goodmorning,
       
      Currently I'm using a cDAQ 9135 shipped with WES7 as OS for a acquisition application. My code is based on the continous acquistion template (event loop, message loop, acquition loop, logging loop and visualization loop) based on data sharing with queues.
       
      Now I wanted to extend this code with daqmx writing blocks as I need to add a closed loop control. However I noticed that my acquisition loop is running too slow for a 'realtime' closed loop control. +/- 20 ms/iteration is the best i can get with a timed loop IF disable the visualization loop. Otherwise it goes to 200 ms/iteration.
       
      To have a closed loop control I read it would be better to have a real time target. Therefore I would need to change the OS of my cDAQ from WES7 to Linux Labview RT. As I understood, then the acquiring/control and logging would run on the RT target and the visualization on a host computer connected by ethernet or usb to the cDAQ.
       
      Now the questions:
      - Will I get better performance by going to the Labview RT solution?
      - Is it uberhaupt possible to change from OS on my cdaq? and if yes, how to do this?
       
      Thank you in advance.
       
      Kind regards,
      bvrm
    • By volatile
      Lets pretend I wanted to simulate a solar panel using a cDAQ, a programmable power supply and a light sensor. Id have to measure the voltage from the light sensor and the PSUs current, use those values to find the respective operating point on my light/voltage/current-curve and update the PSUs settings. Lets also say I wanted to do this for multiple systems in parallel, all connected to 1 analog input and 1 analog output module in 1 cDAQ.
      What would be the best way to achieve the quickest response time? Simply reading and writing single samples seams to be pretty slow (though I can encapsulate everything neatly this way).
      Is there a better way?
    • By FJ_Sanchez
      Hello,
       
      I've been struggling with this problem for months now... I want to use a cDAQ9171+NI-9234 with an Advantech PC (AIMB-580). I have 3 computers like this and all with the same problem. I plug the USB cDAQ-9171, Windows detect the device and loads the proper driver (cDAQ-9171), it is displayed in MAX but self-test or reset always fails with error. At the same time, NI Devive Loader service hangs up. If I try to restart or stop this service it cannot complete the operation, the only way to finish this operation is to unplug the usb cable from the PC, then the service restarts correctly. Additionally the windows' event logger shows the next error message:
       
       
      or
       
       
      In one PC I re-installed Windows, installed DAQmx 14 and the problem was still there, this is with a Windows fresh-install... After this, I removed DAQmx 14 and installed DAQmx 9.8 (supplied in CD) and the it worked!!! I upgraded to DAQmx 9.9 and it was still working, so I stoped there as it was all I needed (9.8 has some bugs with NI-9234 that 9.9 solves).
       
      One thing to note, when it works, Windows first install cDAQ-9171 driver, but then inmediatly it changes to USB flash firmware updater, after this it returns again to load cDAQ-9171 and detects the NI-9134. When it don't work it only installs the cDAQ-9171 and doesn't load anything more...
       
      I tried in a second PC to repeat the process, but I have been not able to repeat the success, only the fail... I get the same error every time I plug the USB and I have not idea of what else try... I have disabled UAC, cleared the MAX data, reinstall windows 2 times, tried with DAQmx 9.8, 9.9 and 14. Forced USB flash firmware updater as Windows driver, changed BIOS settings (disable hyper-threading, VT extensions, USB legacy, etc.). I am almost sure that it is some kind of weird incompatibility or similar, the thing is that NI device loader always hangs-up. In the next days I'm going to try to copy the same exact configuration of BIOS from the working PC, just to be sure.
       
      Any recommendation?
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.