Jump to content

CTRL+SHIFT+ Shortcuts sometimes not working in LabVIEW


Go to solution Solved by Mellroth,

Recommended Posts

  • Replies 66
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I just noticed this this morning, but in Windows 7(x64) running in bootcamp (LabVIEW 2014).   My problem seems related to the input-locale, or more specifically, which keyboard-type that were used.

It is my pleasure to support the forum.  This community is a tremendous resource.

You may be onto something here. This is the result I get when pressing CTRL+SHIFT+E: And here's the snippet in case someone else is able to run on a known-good machine, to compare results: It's

Posted Images

I think this is a repost for me but I'll just re-raise that on some of my VMs, ctrl+shift still works, but on others it doesn't - I have no idea why.  I tried comparing settings and low level settings to no avail.

 

I'm running OSX 10.10.1, Parallels 10.1.1, Win7 x64 VMs running LabVIEW 32-bit.

Link to post
Share on other sites

I just noticed this this morning, but in Windows 7(x64) running in bootcamp (LabVIEW 2014).

 

My problem seems related to the input-locale, or more specifically, which keyboard-type that were used.

 

I’m using an external keyboard but windows defaults to the “Swedish (Apple)†keyboard, and for some reason that keyboard doesn’t forward multiple modifiers to LabVIEW (all keyboards work in MS Word). In this little test VI; pressing shift-a, ctrl-a and shift-ctrl-a should all give me the scan code 30 on my keyboard.

attachicon.gifModifierTest.vi

But the Apple keyboard doesn't react when both modifiers are used. By switching keyboard layout during the VI execution the ctrl-shift-a functionality comes and goes.

 

So, my solution was to go to the control panel and change the default input to use the external keyboard layout instead of the apple-type. I also explicitly changed keyboard type when LabVIEW was open.

 

 

Solved. Sincerely -- thank you! I will report this back via support channels to NI on this issue.

Link to post
Share on other sites

Solved. Sincerely -- thank you! I will report this back via support channels to NI on this issue.

 

You're welcome Jack.

It is actually quite funny that I first noticed the issue right after I read through this thread... ;-)

 

/Jonas 

  • Like 1
Link to post
Share on other sites

Forgive the stupid question, but is this a setting you changed in Windows or in OS X?  It's fantastic to hear that someone finally got to the bottom of this!  I'm having a little trouble figuring out exactly what you did though - forgive me for being slow...

 

 

No worries! It's TOTALLY buried in the Windows settings:

 

First, from Control Panel, search for "Region and Language", then click on "Change Keyboards"

 

post-17237-0-80797100-1417562896.png

 

 

That brings up this window. If you see in your VM what we see below -- only a single "(Apple)" locale -- it's likely your keyboard shortcuts are not working in LabVIEW:

 

post-17237-0-51891300-1417562897.png

 

To solve the problem, "Add" a new keyboard, selecting the US keyboard and setting it as the default. Be sure to relaunch LabVIEW if it was open!

 

post-17237-0-91211100-1417562897.png

Link to post
Share on other sites

First of all... Jonas, you da man. Thank you very very much. This is such a huge help, and I've waited a long, long time for it.

 

Jack's HOWTO didn't work for me (under Windows 8.1) because I oddly don't seem to have the "Keyboards and Languages" tab he mentions. I Googled around quite a bit trying to figure out how to get it to show up, but to no avail.

post-2992-0-74832200-1417573712.png

However, I was still able to fix the problem via basically the same steps along a different route. Maybe this will be helpful to someone....

 

Step 1. Open the Control Panel and select "Change input methods".

post-2992-0-88731900-1417573870_thumb.pn

Step 2. You should see two keyboard layouts installed under whatever your selected language is. Click "Options".

post-2992-0-24053500-1417573963_thumb.pn

Step 3. Click "Remove" next to "United States (Apple) - Parallels".

post-2992-0-89124000-1417574018_thumb.pn

Step 4. Click "Save".

post-2992-0-25894100-1417574080_thumb.pn

Step 5. Note that you've only got one keyboard layout now: "US".
post-2992-0-27812000-1417574114_thumb.pn
Step 6. Restart Windows. (This apparently wasn't necessary for Jonas, but it definitely was required for me.)
post-2992-0-17400500-1417574163.png
 
  • Like 1
Link to post
Share on other sites

For future reference, and perhaps a different way to fix this at the root cause, without monkeying with Windows settings, this Parallels support forum post recommends the following:

 

(copied from the post in case it disappears some day, cleaned up for readability)

  1. Shut down your Windows virtual machine.
  2. From Parallels Desktop menu go to Window -> Virtual Machines List -> right-click on your virtual machine -> select 'Show in Finder' (note this applies to Parallels 8; other Parallels versions have different menus/windows)
  3. Right-click on the .pvm file for your virtual machine -> select 'Show package contents'
  4. Open config.pvs using TextEdit
  5. Locate the "KeyboardLayoutSync" tag and change its 'Enabled' value to '0' (zero)
  6. Close config.pvs, saving changes
Link to post
Share on other sites

Justin, thanks for the Win8.1 walkthru; indeed it's a little different than my screenshots from Win7.

 

One thing -- can you provide another walkthru on where you found that "Restart" button on Win8.1? Bonus points for avoiding the word "gesture".

 

 

( :lol:)

Link to post
Share on other sites

One thing -- can you provide another walkthru on where you found that "Restart" button on Win8.1? Bonus points for avoiding the word "gesture".

Classic Shell to the rescue.  I have Windows 8.1 boot to the desktop, with DisplayFusion and Classic Shell.  It is like Windows 7 but better.  I seriously have never seen the metro interface since installing these.

Link to post
Share on other sites

One thing -- can you provide another walkthru on where you found that "Restart" button on Win8.1? Bonus points for avoiding the word "gesture".

 

If you only knew the "gestures" I've made at my computer over the last 5 years dealing with this issue  :lol: .

OK, so upon applying this fix to my work VM this morning, I found a new wrinkle. The basic cause & steps to fix are the same, but the starting configuration has a minor difference.

 

This is with a brand new Parallels VM created from scratch with Windows 8.1 a couple weeks ago. I installed LabVIEW 2014 and a couple other applications, but it's basically a "clean" VM. I'm posting this since I imagine there will be other people stumbling through here over the months/years with brand new VMs – more than those of us with VMs from Parallels 4, to be sure ;).

 

Anyway, when I went to Control Panel >> Change Input Methods dialog, the only input method installed was the "United States (Apple) - Parallels" one.

 

In order to switch to a different one ("US" in my case), I had to actually Add the "US" layout, then Remove the Parallels one.

 

Interestingly, in this case I did not need to restart Windows afterward. So that's more like Jonas's experience.

  • Like 1
Link to post
Share on other sites
  • 1 month later...

You guys Rock!!!

 

So glad you guys experienced this and that google found this thread!

 

Just got my first Mac, bootcamped into Windows 8.1, loaded LabVIEW 2014 and was pulling my hair out trying to figure out why my ctrl+shift+e wasn't working. 

 

FWIW, after reading the solution and before reading the rest of the thread I jumped to the control panel, didn't see the keyboard option that was mentioned, so I just added the "United States-International Touch keyboard layout" as a third keyboard option. That seemed to fix it without restarting anything. Not sure of the rationale behind that, but just glad I can move freely around my project again!!! (:

 

-Carl Wecker

carl@endigit.com

  • Like 1
Link to post
Share on other sites
  • 8 months later...
  • 1 year later...
  • 1 month later...

And it is here again:

I just installed LabVIEW 2016 on a Windows 10 virtual machine (Parallels 11.2.2) on a mac with OS 10.11.6 - and - none of the above procedures work: Ctrl-Shift-A does not work at all, others from time to time.

Then I also noticed that scrolling in the macintosh version of LV 2016 does no longer work reliably - I can't use the scroll wheel anymore to browse through event-, case- and other structures (I need to try 3 to 5 times, until something happens).

It looks to me as if NI uses its own special functions to receive keyboard and mouse events instead of using the standard operating system functions - as all other programs work fine.

Now, as there is obviously a non negligible number of LabVIEW-developers using virtual Windows-machines on a mac, I would really enjoy NI to check into these issues.

 

Herbert

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.