Jump to content
News about the LabVIEW Wiki! Read more... ×

Recommended Posts

Some important things to note:

 

- The source posted is actually for LabVIEW 2013.

 

- Version 0.3 is an alpha release. Expect to encounter bugs.

 

- Make sure that you add "UseUnicode=True" to the LabVIEW.ini file and restart LabVIEW before running the program..

 
- To start the program, run the "Launcher.vi" located in the "SET Language Editor" folder.

Share this post


Link to post
Share on other sites

Strings supported as of version 0.3.1:

 

Front Panel

- Custom Title

 
Front Panel Decoration Text
- All
 
Block Diagram String Constants (Not located within a structure)
- Extracted if Label Visible
- Labeled String Constants within Labeled Clusters will be extracted.
- Block Diagram Array Strings currently not supported. 
 
All front pane Controls
- Visible Captions
- Tip Strips
 
Boolean Controls
- Visible Boolean Text
 
Ring Controls
- Item Strings
 
String Controls
- Default Value
 
Run-Time Menus
- Item Name if Item Tag doesn't start with APP
Edited by Porter

Share this post


Link to post
Share on other sites

Thank you for making this toolkit free for us all to look at.  I was looking into making a similar (but much less sophisticated) toolkit.

 

A possible update:  The Add Language popup will only let you select from Languages already populated by the developer, ie you cannot "add" a language by typing the language while using the toolkit.  It looks like I would need to edit the Language Selector.ctl to add more languages, then reopen the toolkit in LabVIEW to add the language to my project.

  • Like 1

Share this post


Link to post
Share on other sites

I will look into adding this feature. The reason why I made a static language list was because I link the language to its associated code page. I suppose that it would make more sense to store this information in a config file that the user can modify.

Share this post


Link to post
Share on other sites

I'm currently adding support for 1D string array controls and constants. I will look into moving to LV 2012 after that.

Share this post


Link to post
Share on other sites

Version 0.4.0.1 has a LV2013 and LV2012 package available for download.

 

If you are running LV2013 or higher, please use the LV2013 package. I haven't had time to thoroughly test the LV2012 package.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.