Jump to content

ms timing accuracy over WiFi Tablets using IEEE1588


Chris

Recommended Posts

I used a USB-6001 DAQ unit for a Quiz Buzzer game that worked down to an accuracy of 1ms - great no problems :) .

 

However having to wire up all the buzzers (up to 13) each time was becoming a pain and it doesn't scale very well, so I was looking at using tablets (probably Android based) to transmit over WiFi a virtual buzzer press.  But then of course you have all the latencies etc. of the TCP/IP packets to contend with.

 

I was wondering if it was possible to use the IEEE 1588-2008 standard (Precision time protocol over ethernet) to get similar accuracies - even up to about 20ms accuracy would be OK over a standard WiFi connection?

 

I was thinking you can send a master clock signal (eg. using someting like the JJ Control uS Clock) from a central LabVIEW server application to all the Clients (Tablets) up to 10 times per second as per the standard to keep clocks synchronised.

 

I had a look, but couldn't find a IEEE 1588-2008 LabVIEW toolkit - is there one available?

 

If not is there a simple way of achieving this?

 

Thanks

 

Chris

Link to comment

What are the tablets running?  In a Windows environment you could synchronize all their clocks (to the ms) then when your program runs, send over TCP the time stamp of the event.  Then when your host system gets a buzzer, let it wait say 100ms for any other contestants to buzz in with an earlier time stamp.

Link to comment

Thanks for all the good answers.

1) Unfortuantely the Tablets will be probably be running Android, because they are A LOT cheaper than a Windows based Tablet and I need to get around 20-30 of them.

 

2) I was thinking what the hell is Nagle, but a quick Google search provided the answer...

http://www.optimizemswindows.com/disable-nagle-algorithm-to-increase-your-internet-speed-for-quick-response/

 

Gee if that works it will be really simple - thanks.

 

3) Thanks Gribo for the link to the IEEE1588 Daemon.  I've never had to work with C libraries so I wouldn't have a clue where to start, but if Shaun's idea doesn't work it looks like I'll have to do a bit of research.

 

Chris

 

Link to comment

2) I was thinking what the hell is Nagle, but a quick Google search provided the answer...

http://www.optimizemswindows.com/disable-nagle-algorithm-to-increase-your-internet-speed-for-quick-response/

 

Yes. I tried posting a link to the wikipedia page but the editor kept truncating the address. hopefully this works for you. You are after the TCP_NODELAY option of SocketImpl (set to true)

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By engineeringstudenthelp
      I am currently running Labview on my mac using parallels and a version of windows 10. After installing Labview on the windows virtual machine the wifi no longer worked in the virtual machine. The mac portion of the computer could still connect to the internet without any issue but the windows running on parallels was no longer able to connect. Somehow I was able to resolve the issue with connecting to the internet in windows, but it is saying it is only connecting via ethernet and does not show any wireless networks. I'm attempting connect to a myRIO via wifi but since the windows refuses to show any wireless networking options I am unable to connect. I'm wondering if installing Labview somehow messed up any wireless drivers in windows.  
      Ive also tried all the different kinds of bridged networking types and they do not solve the issue
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.