Jump to content

Help! LabVIEW wont start, even after reinstall or Windows Restore


Recommended Posts

Has anyone ever had a problem with LabVIEW crashing on start even after you reinstalled LabVIEW (and tried Windows System Restore to revert to a point before the problem happened)?

I believe there must be some corrupt file somewhere; I've tried manually deleting the compiled-code cache and the LabVIEW INI file but to no effect.  Can anyone think of any other file that LabVIEW might read on startup?  Where does LabVIEW save the backup copies of VIs (that, after a crash, it asks you if you want to recover)?  I think it could be that.

2017-09-12 10_20_52-Action Center.png

Crossposted on NI.com

Edited by drjdpowell
Link to comment

Have you cleared both compiled-code caches, i.e.

1. The one in <National Instruments>\LabVIEW XXXX\VIObjCache\(...)

2. The one in <Documents>\LabVIEW Data\VIObjCache

I think the recovery files are also somewhere in LabVIEW Data folder... Maybe just try to wipe this whole folder?


Also: the crashes at the startup happens when LV have problems with loading project providers. Any toolkit you've installed recently? Or just go to the <LabVIEW>\resource\Framework\Providers\GProviders folder and remove it's contents to see if LV will start without them, this will narrow down the problem.

Edited by PiDi
  • Like 1
Link to comment
16 minutes ago, PiDi said:

I think the recovery files are also somewhere in LabVIEW Data folder... Maybe just try to wipe this whole folder?

Fantastic idea!   That worked.  LabVIEW 2017 now opens.  Why was I searching through that folder for suspicious items when I could nuke the whole thing?

Link to comment
3 hours ago, hooovahh said:

Glad you got it working (partially at least) my suggestion would just be to repair stuff.  Yeah it takes a while to reinstall MAX, LabVIEW and all the other stuff but it has worked for me most times LabVIEW refuses to start.

Sadly, NI has removed the ability for me to repair any NI installation.  I’m not happy.

Link to comment

I'm currently in the middle of a complete reinstallation of everything.  Everything.  After multiple issues with 2017 crashing, and DAQ-mx not recognizing hardware (I re-installed it after installing 2017, and it was working fine for a couple months).  

wish I had seen this post yesterday, but c'est la vie.

Link to comment
  • 6 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.