Jump to content

Change to some classic control graphics


Recommended Posts

Hello Everyone,

 

I noticed an interesting change today that I thought was worth mentioning.  I've been using the classic system button for some of my UI's.  It's flat and looks clean.  Less busy.  I noticed today that the graphics for this button are different from one of my PC's to another.  My laptop, which is running 2016.0, looks like the original.  My desktop which is running 2016.0f2 looks like the 'different' one.  Both 2016 but one has no depth graphic and one does.  I've dug through the menus folder and it looks like the classic and modern controls are not housed there, which makes sense really since they are probably proprietary.  I'd prefer the original look as it matches with the flat Windows 10 style that's in vogue right now.  Just something I noticed and thought was worth mentioning.

 

Cheers,

 

Tim

systembuttonoriginal.PNG

Systembuttondifferent.PNG

Link to post
Share on other sites

Yes.  They are... however this was out of the classic palette.  Perhaps you've taught me something new.  I was under the impression that only system dependent controls are in the systems palette but I bet you are correct. The system button in the classic palette is OS dependent.

Good catch

Don't listen to my previous posts then because my conclusion was incorrect.

 

Also thank you for your observation.  

 

Tim

Edited by A Scottish moose
Link to post
Share on other sites

I don’t know why the system buttons are also in the “classic” palette, but they are the same controls as in the “system” palette. 

BTW: If you use the non-system buttons you’ll lose the mouse-over “hover” effect (which, personally, I like a lot).   You can instead customize a system button by swiping the change-with-the-os-shapes for regular rectangles or simple PNGs (such as the buttons in Flatline Controls).

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By apoorve kalot
      just following a tutorial on YouTube [https://www.youtube.com/watch?v=Ko0heNZhRvI], for setting objects in lab-view for simulation, doing the steps as stated. as program executes, the resultant spheres, ( which has been added to the 3D picture object, are very far out zoomed ) , done the following steps  to correct it, still no help
      1) seen online help of using "shift + drag" to correct it, but it's still no help,
      2) changed camera position to : none and auto - redraw, still no help,
      since i am new to this, it is request to state the measure to correct the problem and to avoid these problems.
      Along with one question : how to add Co-ordinate axises for reference to it, independent of any other objects, [ i.e. the axises shouldn't be affected by rotation, translation or objects ] in 3D picture object
      edit : same question is posted as well on : https://forums.ni.com/t5/LabVIEW/camera-postion-stuck-in-3D-picture-control/m-p/3990030#M1138526
      trial.lvproj trial_001.vi
    • By drjdpowell
      The attached VIPM contains an extension of Messenger Library that is intended to add extended functionality to controls/indicators, via a background process that is launched and which registers for the events of the control (the background process is a Messenger-Library “actor”).  This is meant to be an alternative to XControls.   Included are two “Augments”, both with examples.  See <examples>/drjdpowell/UI Augments/Examples/EXAMPLE Twin Cursor Graph Augment.  This takes any graph with two cursors and draws a line between the two and displays summary info of the data between the two cursors:

      There is also a cross-section plotting for a 2D intensity chart:

       
      This package is in LabVIEW 2015, and requires Messenger Library (latest, in the LAVA-CR) and JSON LabVIEW and Shortcut menu from Cluster (both in the LAVA-CR).
      drjdpowell_messenger_ui_augments-1.0.0.8.vip
    • By kosist
      Dear LabVIEW community!
       
      I have installed LabVIEW, v13.0f02, 32-bit on my PC. The problem, which I face, is that DAQmx Physical Channel controls, which are used in VIs inside the LV projects, sometimes don't show me the list of DAQ devices - I can't expand the list at all. I push the button to expand the list, but nothing helps.
      But when I create VIs outside the project, and put there DAQmx Physical Channel control - everything works well.
      Note: devices are simulated via MAX.
      Is it some kind of bug in 2013 vesrion of LabVIEW? Because while using LV 2012 I didn't have such headache.
      The only thing that helps now - is to restart PC (laptop) several times; b/c restart of LV doesn't help.
      Can anyone suggest, what it can be, and how to fix this problem?
       
      Thank you very much in advance!
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.