Jump to content
Sign in to follow this  
Taylorh140

working with mixed signal graph

Recommended Posts

I am trying to use a mixed signal graph to plot a set of digital data (12 lines) and 4 arrays of analog data in XY format.  For the analog data I want each array to be assigned to a different group in the graph, but at runtime they seem to all default to Group 1 (the Pressure graph shown below).  I have been able to change them using the legend or the graph properties for each plot, but cannot find a way to do it programmatically.  Is there a property node that can be used to set this?

 

2018-05-08_17-00-19.png

Share this post


Link to post
Share on other sites

I found some information on how to set the group. Since the input types could change it would be good to auto configure the types based on the inputs to the mixed signal graph. I have a basic configuration VI that should do the trick in most cases. It iterates through the cluster items on the input type and based on the types sets the group by setting the Plot.YScaleIdx of the active plot(it also sets the active plot).

It does assume that input arrays will be xy time data in the format:

1D array of (cluster of two elements(1D array of Timestamp),(1D array of double)) //because why wouldn't it?

 

AutoGroupInputs.vi

AutoGroupInputs_BD.png

Edited by Taylorh140
details

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.