Jump to content

NI USB DAQ not recognised after PC reboot

Recommended Posts


I'm having a problem with two of my PCs that have a USB-6356 DAQ connected. Every time the PC reboots the DAQ isn't recognised in NI MAX or LabVIEW or NI Device Monitor.

The DAQ reappears after I power cycle it. Any thoughts what the problem might be?

PC is running windows 10 Pro and LabView 16


Edited by ThomasGutzler
Link to post

I had a real struggle with some USB3.0 cameras and a Windows 10 PC. They were Basler cameras, and even Windows device manager sometimes did not pick them up. They would regularly just "not appear" in MAX. Never managed to solve the problem to my satisfaction and pretty much decided to not use USB hardware.

Link to post

I'd disable PC sleeping and hibernation, disable power management, or set it to performance, and make sure USB ports aren't being put to sleep for whatever reason.  Does this happen on all USB ports?  Is this through a hub?  Beyond that do you have any odd software running that might be scanning for USB devices?  Some employers install software to lock down the PC and it could be interacting with it in a weird way.

Link to post

Thanks for throwing ideas around. Let's debunk some of them.

I don't think it's a hardware problem, because a power cycle of the DAQ wouldn't fix that reliably and a reboot of the PC wouldn't break it reliably. The DAQ is connected to an Intel NUC directly to the onboard USB port. I tried different ones with no luck.

There is no funny software running that interferes with the USB ports

PC is set to never sleep. Power management was enabled for USB hubs, so I turned that off and rebooted the PC. Same problem

Status Code: -88705
The specified device is not present or is not active in the system. The device may not be installed on this system, may have been unplugged, or may not be installed correctly.

Next, I unplugged the USB cable and plugged it into a different port and the DAQ showed up in MAX. Rebooted the PC and it was still there.
Turns out not all USB ports are the same. Previously I only tried the ports at the front of the NUC. This time I tried one at the back. That fixed it on both PCs.

Fix: Don't plug your USB DAQ into a "charging USB port"

Edited by ThomasGutzler
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.