Jump to content

Recommended Posts

Hi,

I'm having problems building a vipc from a vipb with files containing nested vims. Getting the following error from VIPM:

ERROR: 7: VIPM API_vipm_api.lvlib:Parse Build Return Message_vipm_api.vi<ERR>
Code:: 7
Source:: 0053C289D635723F5DC0A4F08297566A<ERR>
The following source VIs or Libraries are missing.
Please correct this problem before rebuilding.

b39afad9-8321-4719-86a9-dddab325fc87.vi

The following source VIs or Libraries are the callers of missing files

BitsSetter.vim

I created a zip with the vims and the vipb file. Any suggestions how to fix this?
Opening the files shows no errors. Replacing the nested vim with its actual implementation fixes the problem but I don't want to give in just yet.

I'm on LV 18.0.1f4 64bit with VIPM 2018.0.0f1

Cheers

bits.zip

Edited by ThomasGutzler
  • Like 1
Link to post
Share on other sites

It looks like the issue is putting nested VIMs in a class.  See https://forums.jki.net/topic/2641-vi-calling-vim-fails-to-build-fixed-in-vipm-2017f1/ and https://forums.ni.com/t5/LabVIEW/VI-Package-Manager-Fails-to-Build-with-Malleable-VIs-VIMs/td-p/3871468.

@Jim Kring If you are still looking for a simple reproducing case of this bug, here is one.

Link to post
Share on other sites
  • 2 weeks later...
On 11/21/2019 at 10:01 AM, ThomasGutzler said:

Good find!

@Jim Kring happy to assist in any way I can when you're looking into this bug.

Jim does not come to LAVAG often (e.g. see https://lavag.org/topic/21017-where-are-openg-product-pages-for-packages/?do=findComment&comment=129287 )

I'd imagine you'd get a lot more interest if you post at the JKI forums

 

13 minutes ago, ThomasGutzler said:

Unfortunately, nobody seems to care about this any more :(

Nested malleables + VIPC is not a combo that I use :)

Link to post
Share on other sites
19 hours ago, ThomasGutzler said:

I replied with an example on the relevant thread on the JKI forum

You might want to post a link to this thread in that thread.  The attachment is listed as unavailable - the error message says "This attachment is not available. It may have been removed or the person who shared it may not have permission to share it to this location".  Brian's original attachment is also listed as unavailable.

Maybe that was JKI's problem all along - they wonder why no one sends them examples while not realizing that they don't allow anyone to post code.

Edited by TomOrr0W
Link to post
Share on other sites
17 minutes ago, TomOrr0W said:

The attachment is listed as unavailable - the error message says "This attachment is not available. It may have been removed or the person who shared it may not have permission to share it to this location".  Brian Hoover's original attachment is also listed as unavailable.

I can download them both. Maybe you need to have an account for the download to work. I had to create an account to be able to upload.

Link to post
Share on other sites
  • 1 month later...
  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.