Jump to content
Michael Aivaliotis

NI update and package manager eating hard drive space.

Recommended Posts

I work with VMs and monitoring VM drive space is one issue I look at every now and then.

The "C:\ProgramData\National Instruments" folder on one of my VMs is using 40GB. Does anyone know the proper way to clean up the NI crap?

Using SpaceSniffer, it show the bulk of it is used by the Update Service and NI Package Manager. I'm sure it's just leftover installers that may be needed.

Share this post


Link to post
Share on other sites
26 minutes ago, Michael Aivaliotis said:

Does anyone know the proper way to clean up the NI crap?

Using SpaceSniffer, it show the bulk of it is used by the Update Service and NI Package Manager. I'm sure it's just leftover installers that may be needed.

I don't know if a "proper" way exists, hence https://forums.ni.com/t5/NI-Package-Management-Idea/Add-ability-to-reclaim-space-taken-by-cached-packages/idi-p/4024241

I've been manually deleting the *.nipkg files, and the very old folders in C:\ProgramData\National Instruments\Update Service\Installers, without ill effects to my day-to-day work.

I think NI Package Builder or LabVIEW Application Builder can't bundle a dependency if its package or local installer is gone, however.

  • Like 1

Share this post


Link to post
Share on other sites

Ok, now your idea has 2 votes... 😀

Ya, I decided to delete them all manually, and also the Update Service installers, which are probably temporary packaged files for the update service.

Share this post


Link to post
Share on other sites

So just adding info here for future googlers.

There is an NI KB article on how to cleanup the cache here: https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z0000019KdtSAE&l=en-US

In there it also mentions an ini token that eliminates cache creation completely:

Quote

you can add a token to your nipkg.ini to prevent the caching of packages in the future. The nipkg.ini is located at \%localappdata%\National Instruments\NI Package Manager\nipkg.ini.

Make sure you add the token below the [nipkg] line so it looks like:
[nipkg]
cachepackages=false

 

  • Like 1

Share this post


Link to post
Share on other sites

Actually, the nipkg.ini is in \ProgramData\National Instruments\NI Package Manager\Settings\nipkg.ini

Share this post


Link to post
Share on other sites
1 hour ago, X___ said:

Actually, the nipkg.ini is in \ProgramData\National Instruments\NI Package Manager\Settings\nipkg.ini

I guess nI needs to update that article. 😉

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.